Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

tarjan

macrumors 6502
Original poster
Aug 11, 2006
251
7
For some reason 11.0.1 is having failures with time machine when connecting to a samba share with time machine configured. Hosting system is ubuntu 20.04 with current samba. configuration worked properly with catalina.

Issue seems to be how it is creating the sparsebundle, the system states it does not have permission to modify the files it has just created. Then of course it fails and I'm back to square one.

I've tried to force permissions through samba, but I'm not much of an SMB expert.


Failed to create '/Volumes/.timemachine/"servername"._smb._tcp.local./"...".sparsebundle', results: {
}, error: 13 Permission denied

permissions for the sparsebundle file are : drw-------

vfs objects are catia fruit xattr_stream
time machine is yes for this share

it is writable. I can open the same share with the same username and have full access.

Any ideas?
 

Stq

macrumors member
May 1, 2016
49
54
I ran into the same issue and ended up working around it by creating the sparsebundle through AFP and then switching back to SMB.
 

tarjan

macrumors 6502
Original poster
Aug 11, 2006
251
7
Man, I was hoping to not have to do that. I don't have AFP setup in my ubunto box and too lazy to redo it. :)

Did you report the issue in the feedback app? If not, please do. While they ignore some, the duplicates get their attention it seems.
 

gordon1234

macrumors 6502a
Jun 23, 2010
574
163
in smb.conf, try adding this:

Code:
fruit:nfs_aces = no

Then clear out any partially-created sparsebundles from the Backup directory, restart samba, and try again.
 

DimaVR

Suspended
Nov 14, 2017
1,146
477
I was backing up to two drive in my network lost one due to this bug permission garbage lol.

I’ll wait for the fix makes no sense no changes were made for years one drive TM failed to connect cause if this but I can browse it fine other network drive keeps backing up
 

lukask13

macrumors newbie
Nov 17, 2020
4
1
I'm using ext4 on the one host without explicit ACLs (used it for two years without any problems) and glusterfs on the second host. Same error for both hosts.
 

bed

macrumors member
May 26, 2008
97
2
I'm was having the same issue:
* ubuntu 20.10
* ext4 drive
* the fruit:nfs_aces did nothing
* previously working fine pre Big Sur etc

adding acl_xattr to my vfs objects config enabled the sparse bundle to be created without error.

Code:
vfs objects = acl_xattr catia fruit streams_xattr

lets see if it completes :)
 
Last edited:

bed

macrumors member
May 26, 2008
97
2
I'm was having the same issue:
* ubuntu 20.10
* ext4 drive
* the fruit:nfs_aces did nothing
* previously working fine pre Big Sur etc

BUT adding acl_xattr to my vfs objects config enabled the sparse bundle to be created without error.

Code:
vfs objects = acl_xattr catia fruit streams_xattr

lets see if it completes :)

So far so good, over half way through a fresh backup 🤞🏼
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.