Time Machine + Western Digital Shared Space

Discussion in 'OS X Mountain Lion (10.8)' started by JoelBC, Oct 6, 2012.

  1. JoelBC macrumors 6502a

    Jun 16, 2012
    I have done a forum search and could not find any information on this so apologies to the extent that this has already been asked...

    I have a Western Digital SharedSpace NAS...I upgraded the firmware and noticed that i) AFP support has been added and ii) a new used named "WD-Backup" (with "Full Name" Time Machine User) has been added which, interestingly enough, can not be deleted/removed...

    I thus believe that my NAS drive supports Time Machine but have been unable to get it to work as I can not / do not see the drive among the list of available drives (and, this may be the first of the issues I can / will encounter)...

    Though I am a long time Windows user I am a little lost as a new Mac user and would appreciate assistance in navigate this task as I want to get my backups working before migrating platforms...

    Would be ideal if someone with an exact / similar NAS be able to respond.

    Thanks in advance,

  2. Hileotech macrumors newbie

    Oct 7, 2012
    Don't know if this might be helpful, but...
    I have a MyBook Live (ok, it's not your very NAS, but...) and noticed the same new "TimeMachine" space.
    I immediately tried to use this new TimeMachine resource as my backup, but I couldn't see it in TimeMachine settings... until a few hours ago: I don't know why, but as I tried to configure once more TimeMachine, I could see this share. As I'm writing to you I'm backing up my MacBook...

    So: don't ask me what I did, because I didn't do ANYTHING. Don't ask me what happened (might be a new set of IP's in my router? might be DHCP needed a few days to "see" the new share?). I only know that after some time everything works...

    PS: if you ask me, yes: it seems me odd enough to think I'm back into Windows world... :cool:
  3. MiniMi macrumors member

    Dec 29, 2011

    I have the 6TB MyBook Duo NAS and it has worked out of the box with all my MACs. My recommendation would be to re-run the WD Assistant software. If you don't have it you can download it from the WD site. If you did a firmware upgrade, it might be necessary to run the softare to enable Time Machine back ups on the NAS.Since you don't provide any specifics on what computer(s) your running I can't be more specific. Another option is to try restarting your computer to force it to reacquire the available shares on your network.

    Hope this helps
  4. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    Thanks to both...I will give it a try and let you know...

  5. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    Thanks to both...I did reboot the NAS and am now able to see it using WD Discovery...I am now going to try a Time Machine backup and see how that goes...

  6. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    Hi Guys...need a little again...I am still working on this and tumbled across the following the information where the URL is https://discussions.apple.com/message/19025364#19025364 and the key post of interest reads

    ...By default the WD Sharespace creates a hidden share called 'WD_Backup' and a user called 'wd_backup' with a default password of 'backup'.

    Using the example in the blog : sudo tmutil setdestination afp://user:pass@host/share

    ...and assuming the following (all default settings with the exeption of the WD Sharespace Server name) -
    Server Name: TimeMachine
    Volume Name: DataVolume
    User: wd_backup
    Password: backup

    you should execute the following at the terminal:
    sudo tmutil setdestination afp://wd_backup:backup@TimeMachine/WD_Backup

    In addition, you can validate you are using the correct UserID/Password, by:
    - Launching the Finder and click on 'Go' from the menu
    - Click on 'Connecto to Server...'
    - in the Server Address field, enter: "afp://TimeMachine/WD_Backup" and click 'Connect'
    - you'll be prompted to enter the UserID and Password to the share; assuming you have not changed either, the default is UserID: wd_backup and Password: backup.

    If your machine cannot resolve the TimeMachine Server name, then replace "TimeMachine" with the IP address of your WD Sharespace Server.

    ..this will mount a drive to the WD_Backup folder, underwhich you will find the <machine_name>.sparcefile that TM uses to store your backup. All this is covered in the WD Sharespace User Guide on page 46 under the TimeMachine configuration section...

    As noted in my OP I am new to Mac and unfortunately continue to struggle with a number of items...a few questions:

    1. Am I correct that user = wd_backup and password = backup are specific to the hidden WD_Backup share [NOTE: I found the "hidden share" which was not so hidden, could verify the user, could not verufy the password].

    2. Do I need to use the hidden share titled WD_Backup or can I use any share?

    3. I find connecting via the NAS/server name to be less than reliable...with my server being located at does this mean that the command that I need ti enter is:

    sudo tmutil setdestination afp://wd_backup:backup@

    4. With the above done then should I be able to use my ShareSpace NAS for TimeMachine, is it that simple?

    5. What if I want to use another device / drive for TimeMachien down teh road...will the string that I entered in 3. above make that difficult [i.e. need to be re-entered to point at the new share]?


    Thanks for all the help,

  7. rhoydotp macrumors 6502


    Sep 28, 2006
    this is not an answer to your last question but I believe it's related to your issue. i wrote this blog entry on how to do time machine to another AFP host so that I don't forget how to do it, it was directly based on another blog that did it on NFS.


    Hope this helps ... and I'm using a WD as well :)
  8. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    Thanks...will try both later tonight and report back...
  9. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    An update as well as a few follow up items:

    1. Update

    I was successful in getting time machine...

    It was simple in that I followed the instructions three up form this post...I think the secrete sauce was mounting the WD NAS via AFP rather than SMB...I believe this to be the case because a WD Engineer told me that there were problems with SMB which explained my experience that the WD NAS would appear / disappear / appear / and so on...whether this is true or not I do not know.

    The one thing that I do not like about this setup is the need to use the WD "specific share" named WD_Backup rather than putting it wherever I want but so be it, at least it works.

    2. Follow Ups

    1. I initially had problems mounting the WD_Backup share because it is hidden though it does appear to mount consistently once the first TimeMachine "slice" has been taken.

    Anybody have any ideas or insights as to why?

    2. Following on 1. above I noticed that when I mount the WD_Backup share I sometimes a) see a mounted drive titled WD_Backup which contains a file called "MacBook Air.sparsebundle" or ii) see a mounted drive titled Time Machine backup [which is the long name for the WD_Backup share] which contains a file called Backup.backupbd or iii) see both i) and ii).

    Anybody have any ideas or insight as to what the differences between the two files are and why this behavior occurs on an inconsistent basis?


    I hoped that this helped and thanks in advance,

  10. rhoydotp macrumors 6502


    Sep 28, 2006
    the name that you see is the name that you specified when you create your sparsebundle.

    i think that if the sparsebundle is not mounted yet, you see the drive "WD_Backup" bur once you (or the machine) mounts the sparsebundle, you will also see the name that you specified for the sparsebundle when you initially created it.

    once the timemachine starts scheduling the backup, it should start mounting the sparsebundle on the background, once it completes, it may unmount it but it should work next time the backup runs.
  11. JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    A little confused here but here goes:

    1. I think, per the instructions referenced above, that WD_BAckup is the name of the share and hence where the sparse bundle resides which is consistent with what I am seeing.

    2. I further think that TimeMachine is the drive "inside" the sparse bundle where the different backups / "snapshots" reside.

    Appreciate your assistance and hope that others will being us closer to the answer.


  12. rhoydotp macrumors 6502


    Sep 28, 2006
    quick question: is your time machine working and backing up into the afp share?

    btw, the sparsebundle is a pseudo-drive so it will act and will be treated as one by the OS.
  13. JoelBC, Dec 6, 2012
    Last edited: Dec 6, 2012

    JoelBC thread starter macrumors 6502a

    Jun 16, 2012
    Yes, it is working without any issues or problems.

    Correct...what I see happening is the following:

    1. I can no longer -- no matter what I do -- get Finder to mount the WD-Backup share...no idea how / why it worked last time...

    2. I can get Finder to mount / show the sparse bundle which is named Time Machine and appears as an external drive by simply entering and exiting time machine.

    I hope that this helps...

  14. rayward macrumors 68000

    Mar 13, 2007
    Houston, TX

    I have tried the above, but I am a complete novice when it comes to using the Terminal etc. When I pasted in the script, the Terminal reports that "The backup destination could not be set".

    My backup drive is called WDSharespace-Backup, I do not know how to find the IP address.

    Can anyone help me adapt the above scripts to fit my drive name?

    Much obliged.
  15. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    You need to answer these questions:

    1) What is the NAS drive formatted as?

    2)Does the NAS have an IP and can you mount it by the command button+k using it IP or do you have to use the smb command?

    So please answer these questions.

    Finally if you are connecting via SMB then bookmark and follow the instructions at the blog post Configuring OS X Mountain Lion Time Machine to Work With CIFS (SMB) Share. See if this works for you if you use SMB to connect to server share (and it is mounted).
  16. chalmers4three macrumors member

    Jul 15, 2012
    i just got the WD Live as well and i too see the WDSharespace-Backup drive in my share drive section on my mac but i cannot connect to it and i cannot find it in the setup. I have my timemachine backing up to a folder i created on the drive but would like to backup to the drive that the WD seems to have created. anybody know how to do this?
  17. rayward macrumors 68000

    Mar 13, 2007
    Houston, TX
    Unfortunately, these are all questions I cannot answer due to my own ignorance. I set up the drive using WD's utility, and it worked fine with Snow Leopard. Then the Lion update broke it, but a slow-to-arrive firmware update fixed that. Then Mountain Lion broke it again, and there hasn't been a firmware update fix in the 8 months since.

    The drive mounts as WDSharespace and WDSharespace-Backup. I can access the former (which is empty), but not the latter, which is where (I presume) my existing Time Machine backup is stored.

    Any help in pointing me in the right direction for the answers you require would be appreciated.

Share This Page