Time on the menu bar is stuck

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SheepNutz, Jan 18, 2008.

  1. SheepNutz macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #1
    Ok, so I just noticed earlier that the time on my iPhone is stuck at 9:42AM. When the phone is locked, and I hit one of the buttons, the correct time is shown at the "slide to unlock" screen, but on the home screen, at the top in the menu bar, the time is stuck at 9:42AM. It's also stuck like that when I'm in safari, or just anywhere that's not the "slide to unlock" screen. I've tried restarting, and when it restarts, the correct time will be shown for a brief second on the menu bar, but then it goes back to 9:42AM. Has anyone seen this before, and does anyone know how I can fix it? BTW, I'm running jailbroken 1.1.1 on AT&T. Thanks.
     
  2. SheepNutz thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #2
    Anybody? It's still stuck on 9:42AM. I've tried setting up the time manually, and that doesn't help either.
     
  3. SheepNutz thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #3
    Ok, this is really weird. There are others that are reporting that their iPhones are stuck at exactly 9:42AM, which also happens to be the time that is on the iPhone in all of apple's ads. All the people that seem to be having the problem have only had this happening to them for the past few days. Here are two threads about people with the same problem.

    http://gwhiz.wordpress.com/2007/06/20/always-942-am-iphone-time/

    http://www.iphone-hacks.com/forums/post-2731.html

    Anyone else here have this issue?
     
  4. dsgalit macrumors member

    Joined:
    Nov 13, 2007
    #4
    Ok i dont know if you have a jailbroken iphone and installed the extended prefs app. but if did, you have to go into that app and turn off the fake time option. There are a couple of options you can do with it, you can use that fake time option or use your own custom text. dont know if this will help but try it out...
     
  5. SheepNutz thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #5
    I think you're on to something! I did install the extended prefs app, but then I uninstalled it, without changing any settings. Does it set the fake time on as default? Now I can't find extended prefs in installer anymore, so I can't reinstall it to turn the function off. Is there another source on installer that I can add so I can get extended prefs back?
     
  6. SheepNutz thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #6
    I finally got it fixed. I had to go into the iPhone's directory via SSH, navigate to /private/var/root/Library/Preferences and delete the file com.apple.springboard.plist.
     

Share This Page