Time Problem

Discussion in 'Jailbreaks and iOS Hacks' started by firstrest, Feb 15, 2008.

  1. firstrest macrumors member

    Joined:
    Oct 12, 2006
    #1
    I used ZiPhone to activate/jailbreak & unlock my UK 1.1.2 OOB phone. I am running 1.1.3 with the 04_02_13 BB. My problem is that the option to set time automatically in Settings->General->Date & Time, has disappeared. I have noticed that if I put my T-Mobile SIM in, the option is there, but with my non-iphone O2 SIM, it isn’t.

    This is a real pain. I’d be hugely grateful if anyone can point me to a fix.
     
  2. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #2
    I wonder if it's a network specific problem. Perhaps T-mobile has a compatible service, but O2 doesn't. Though, you'd think that 02 would - given that it is the official iPhone network.

    Did you previously do a lot of customisation to your iPhone?
     
  3. firstrest thread starter macrumors member

    Joined:
    Oct 12, 2006
    #3
    It was there in 1.1.2, it should be there now. Anyone know where the preference file for this is located, I could maybe have a look there? Munroe: not really, just the standard hcktivation on 1.1.2
     
  4. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #4
    I've had an iPhone from O2 Contract since 1.1.2 and had it upgraded to 1.1.3 and both times I've never had an automatic time setting there no matter how much I have looked.

    Also, watch out because sometimes when the time is automatically updated from Cell towers, the time on the towers can sometimes be wrong and means that it keeps changing your iPhone time to a wrong time and back. ;)

    Just sync it with your computer every so often and the time should update then :)
     
  5. firstrest thread starter macrumors member

    Joined:
    Oct 12, 2006
    #5
    Thanks Domness. Thing is I had it in 1.1.2, and looking at the 1.1.3 phones in the Apple store, they also have it. It's just a pain as it means I have to manually reset my phone every time I travel to a new time zone, which as I'm in the travel industry, is about 10 times a month. Guess I'll just have to live with it. Cheers.
     
  6. AlecEdworthy macrumors 6502

    AlecEdworthy

    Joined:
    May 1, 2007
    Location:
    Leicestershire, UK
    #6
    With my Nokia I had the option available but it didn't work on O2 in the UK (Orange does though). When I go to the USA with the Nokia and it joins the network over there (Cingular IIRC) then I get automatic time updates.

    Since having my iPhone the option has never been there for me (1.1.2 OTB, Jailbroken, O2 non-iPhone contract) nor does it appear on my friend's iPhone (again, 1.1.2 OTB, Jailbroken, O2 non-iPhone contract).

    Alec
     
  7. firstrest thread starter macrumors member

    Joined:
    Oct 12, 2006
    #7
    That's interesting. As I said, I had it in1.1.2 and it worked well when going abroad, mainly to the states and far east, but arriving back in the UK, it was poor at updating. Toggling the 'set time automatically' option from off to on, would update the time though. If it's not there on you guys' phones, is it then set to off by default?

    Just edited to add, as I mentioned in another thread, the option is there when you use ZiPhone to activate and JB an update to 1.1.3, it's when you unlock that it goes. Unfortunately without unlocking there is no mobile service even with a non-iphone O2 SIM.
     
  8. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #8
    I'm in a similar prob to the OP..

    I was previously on 1.1.1 unlocked/jailbroken etc.. and I always had the option even with my O2 (non iPhone contract) sim.. and also a t-mobile sim..

    I've upgraded to 1.1.3 and unlocked etc.. using ziPhone and strangely, the option has gone :(

    If someone knows if this option can manually be turned on via plist file, then please let us know.

    It's annoying, as I'm hit with the sms order being out of sync issue, and Apple's fix is to Set Automatically to ON. At the mo, i don't know if mine is ON or OFF.

    Thanks
     

Share This Page