Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Siddze

macrumors newbie
Original poster
Jul 8, 2020
8
0
I used to use the Command [sudo sntp -sS time.apple.com / sudo sntp -sS in.pool.ntp.org] in the Terminal to sync the System Clock in macOS Catalina. It was working just fine. I now see that with the same Command, the Clock offset isn't getting corrected sometimes. Did the sntp daemon change in MacOS Big Sur? Are there any other Command line I could use.
 

Siddze

macrumors newbie
Original poster
Jul 8, 2020
8
0
Well with the updating of MacOS Big sur, I am seeing a 2 - 4 s difference quite often, which I never observed before with previous MacOS. What is the update interval of [timed(8)] ? Also is this Command [sudo sntp -sS time.apple.com / sudo sntp -sS in.pool.ntp.org] all right?
 

fivenotrump

macrumors 6502a
Apr 15, 2009
539
314
Central England
Well with the updating of MacOS Big sur, I am seeing a 2 - 4 s difference quite often, which I never observed before with previous MacOS. What is the update interval of [timed(8)] ? Also is this Command [sudo sntp -sS time.apple.com / sudo sntp -sS in.pool.ntp.org] all right?
there is no set update interval. I have never seen system time off by more than a dozen or so milliseconds. You have set up time sync in System Preferences using a reputable source I suppose? If so, check that it's running.
 

Siddze

macrumors newbie
Original poster
Jul 8, 2020
8
0
Date & Time section is all set right. Also Command lines [sudo sntp -sS time.apple.com / sudo sntp -sS in.pool.ntp.org] aren't working to set the time which used to work with previous MacOS. Any idea why Apple did this?
 

Feek

macrumors 6502
Nov 9, 2009
408
344
JO01
I have exactly the same problem - Often when waking my iMac from sleep I see a time error of two or more seconds and I'm unable to manually correct it using sudo sntp -sS pool.ntp.org in the same way I would before.

For example, this was just a few minutes and and it shows me that it's two seconds out but simply won't correct it.

7CmOYvF.png


Why do you want to do this manually? Let the system [timed(8)] do its thing.

The system does it eventually but there's no rhyme or reason as to how long it takes. For me, a two second inaccuracy means I can't operate my ham radio station properly as timing is utterly essential for the FT8 and FT4 data modes. If I wander into my radio shack and wake up the Mac, I want to use it straight away, not have to wait for the system to arbitrarily decide when it wants to set the clock.

Disabling time sync and re-enabling it from system prefs / date & time doesn't force it. Running sudo sntp -sS pool.ntp.org no longer forces it like it did in Catalina.
 
  • Like
Reactions: Steve_Jones

gilby101

Contributor
Mar 17, 2010
811
376
Tasmania
Just running the Mac as a time server doesn't mean the Mac will synchronise itself against that server, does it?
My understanding is that if you run an NTP server it does update the host as well as provide time for clients. And I assume you would need to disable Apple's timed service. Worth a try in your case, though you may still need to wake your Mac well before you require accurate time.
 

Feek

macrumors 6502
Nov 9, 2009
408
344
JO01
Worth a try in your case, though you may still need to wake your Mac well before you require accurate time.
So no different to how it is now then. Thanks but I don't think that's a solution.

It would be nice if the sudo sntp -sS pool.ntp.org actually worked as it should.
 

Feek

macrumors 6502
Nov 9, 2009
408
344
JO01
Here we go again.

WYYXkOJ.png


This time it's four seconds out. It's been awake about half an hour. Nothing I can do will force it to update. I've tried turning off time sync and turning it back on. No good.

I have submitted a bug report to Apple for this.
 
Last edited:

jpotisch2

macrumors newbie
Jan 5, 2021
4
6
Same issue. The only workaround I found was to manually set the time, run sudo sntp -S time.nist.gov (also used time.apple.com) to see how far off I was, and then repeat until I got it under a second. If I set it back to setting the time automatically though it immediately returned to the previous inaccuracy. Very frustrating.
 

Siddze

macrumors newbie
Original poster
Jul 8, 2020
8
0
Here we go again.

WYYXkOJ.png


This time it's four seconds out. It's been awake about half an hour. Nothing I can do will force it to update. I've tried turning off time sync and turning it back on. No good.

I have submitted a bug report to Apple for this.
The only thing you could do rather is to put back the time manually few hours and then Recheck the Auto Date & Time. This brings the clock back to the time often around +- 1 s of the right time. Also notice that Apple restricts to make any changes in the Time Server other than time.apple.com. The moment you toggle back/ lock the Date & Time settings, the default Apple time server comes back.
 

testone879

macrumors newbie
Mar 1, 2021
1
0
Hi all, I have been able to force the time update by killing the process named "timed" (from Activity Viewer or Terminal). The process was then respawn automatically by the system, and then time sync actually happened. My clock was off by more than 6 seconds, possibly never synced since the last macOS 11.2.2 update.
 

rhcohen

macrumors newbie
Mar 15, 2021
4
2
Just noticed this thread. I have had this problem also, on the various flavors of macOS 11, but I find that timed does periodically resynch -- unfortunately, not to quite the right time. Always off by 10's of ms. Which I think can matter for some low latency bi-directional audio applications. With previous OS's, the time error (as measured by sntp is always at most a few ms, often around 1 ms or less. Killing the "timed" process and then having it respawned does not change this picture -- it forces a synch to a time off by 10's of ms.
 

Siddze

macrumors newbie
Original poster
Jul 8, 2020
8
0
Unfortunately with the latest update of MacOS Big Sur, the problem persists. Apple has also taken away the option of customizing the Time Server in Date & Time module. The default is now set time.apple.com and it doesn't accept any other time server. The time accuracy has come down as well. Also killing the "Timed" process and letting it respawned corrects the time only to less than a second, but the finer correction seems happen in steps. Are there other sntp Clients for MacOs?
 

rhcohen

macrumors newbie
Mar 15, 2021
4
2
It looks like chrony (chrony.tuxfamily.org) might do what is required. But also I have an active support case open with Apple about this. They are having me provide data on time synch running on the same machine from separate partitions running Catalina and Big Sur.
 
  • Like
Reactions: Feek

Steve_Jones

macrumors member
Jan 26, 2019
30
11
Unfortunately with the latest update of MacOS Big Sur, the problem persists. Apple has also taken away the option of customizing the Time Server in Date & Time module. The default is now set time.apple.com and it doesn't accept any other time server. The time accuracy has come down as well. Also killing the "Timed" process and letting it respawned corrects the time only to less than a second, but the finer correction seems happen in steps. Are there other sntp Clients for MacOs?
I’m running 11.2.3 and I was able to manually type in pool.ntp.org which seems to stick.

I was out .067 but after changing the server, I’m now out .0011.

FT8 on ham radio requires a precise clock and I did notice last week that my timing had crept up compared to other stations.
 

Feek

macrumors 6502
Nov 9, 2009
408
344
JO01
I've installed Chrony and as far as I can tell, it's working. I disabled the built in time and added an @Reboot line in cron to run chronyd and it seems to be working. I have no idea if that's how it's supposed to be done as I can't see any instructions on running it.
I can see it's there if I do a ps-eaf | grep chronyd and if I run chronyc and enter 'tracking', I get this:

Code:
Reference ID    : 55C7D664 (85.199.214.100)
Stratum         : 2
Ref time (UTC)  : Sun Mar 21 12:21:27 2021
System time     : 0.000036185 seconds slow of NTP time
Last offset     : +0.000194381 seconds
RMS offset      : 0.000161701 seconds
Frequency       : 14.694 ppm fast
Residual freq   : +0.001 ppm
Skew            : 0.103 ppm
Root delay      : 0.009506178 seconds
Root dispersion : 0.002018314 seconds
Update interval : 516.0 seconds
Leap status     : Normal

I assume the Ref time is the last time it did a check and that's about half an hour ago.

Chrony is very detailed but not exactly straightforward. I think of myself as quite computer literate but this is a bit of a struggle.

But also I have an active support case open with Apple about this.
I'd much rather have the OS work properly than have to use a third party tool.
 
  • Like
Reactions: gilby101

gilby101

Contributor
Mar 17, 2010
811
376
Tasmania
Chrony is very detailed but not exactly straightforward.
This might help https://whatroute.net/chronycontrol.html

I have experimented. ChronyControl makes configuration easy. As they say "it just works". The only config change I have done is to tell it to use au.pool.ntp.org, and ChonyControl made that easy.

This is really just interest for me as my iMac certainly kept good enough time. It has gone from being consistently 60mS wrong to less than a 1ms.

Reference ID : A29FC801 (au.pool.ntp.org)
Stratum : 4
Ref time (UTC) : Mon Mar 22 00:30:07 2021
System time : 0.000032768 seconds fast of NTP time
Last offset : -0.000009610 seconds
RMS offset : 0.000318758 seconds
Frequency : 43.667 ppm slow
Residual freq : +0.004 ppm
Skew : 0.492 ppm
Root delay : 0.024964849 seconds
Root dispersion : 0.001539077 seconds
Update interval : 65.1 seconds
Leap status : Normal

Edit:
I have written up my use of ChronyControl as an answer to this StackExchange - AskDifferent question.
 
Last edited:
  • Like
Reactions: Feek

Feek

macrumors 6502
Nov 9, 2009
408
344
JO01

gilby101

Contributor
Mar 17, 2010
811
376
Tasmania
I wasn't able to unload timed because it wants me to disable SIP first
I need to correct that in my write up. I have SIP disabled and didn't spot that problem. If you use ChronyControl it sets the time server used by timed to something impossible - so timed can't try to set the time and it uses very few system resources.

I keep my iMac on all the time, so the amount if time it takes to get the clock into correct sync is not important. But I noticed on my MacBook (which sleeps frequently), the time is wrong on wake (by about 2 seconds) and takes a little while (10 minutes or more) to get correct again. I think/hope there are Chrony settings to speed that up, but I haven't investigated that yet.
 

occamsrazor

macrumors 6502
Feb 25, 2007
398
11
It looks like chrony (chrony.tuxfamily.org) might do what is required. But also I have an active support case open with Apple about this. They are having me provide data on time synch running on the same machine from separate partitions running Catalina and Big Sur.

Did your support case ever get resolved by Apple?
 

rhcohen

macrumors newbie
Mar 15, 2021
4
2
Not really. I was told the info had been forwarded to "the engineers" and so hopefully would be addressed via an OS update. At least as of Big Sur 11.5.1, it hadn't been. I haven't yet installed 11.5.2. So I continue to use Chrony, which does seem to keep the clock well synchronized.

As it turns out, the lack of synchronicity between my Mac clock and a standard time server wasn't the source of my problem (glitchiness of audio in a multi-participant audio program (Jamulus)). I tracked down my problem as resulting from a lack of synchronicity between my Mac and my external USB microphone, and was able to address it by forcing the mic to use the Mac's clock (via setting up a composite device in Audio Midi Setup).
 
  • Like
Reactions: occamsrazor
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.