Time to archive lots of old MPEG-2 vids... help!

Discussion in 'Digital Video' started by T Coma, Feb 18, 2016.

  1. T Coma macrumors 6502

    T Coma

    Dec 3, 2015
    People's Republic of Chicago
    Hi all,

    I've got a video archive project that I've been putting off for much too long. I've got a solid 6 years of family home videos recorded on a 2007 Panasonic SDHC video camera. I copied the files from the camera HD directly to my desktops (PC and later Mac). The files are in their native MOD format, with accompanying MOI and PGI files. I don't know what the latter two are for, but the video data is in the MOD file. Playing the "raw" MOD file on the iMac via iMovie / VLC / Quicktime results in an interlaced, horizontally compressed (4x3) aspect, although with a sharp picture. I have tinkered over the years with Handbrake, Wondershare, and Toast to find the best workflow for converting / archiving, but never really settled on the best way to convert the files to the correct aspect while retaining the highest quality and reducing the file size (if applicable). To be honest, I've found the whole digital video realm a bit overwhelming.

    Keep in mind, none of these are pro-level recordings, etc., these are just family home videos. While they won't be used for theatrical release projects, so pro-level processing isn't the goal, but that doesn't mean I don't want to retain as much quality as possible. I certainly don't want the final product to look worse than the original. These individual files could be cobbled into compilations to be given to grandparents, etc. on DVD or just kept on HDD for later nostalgic viewing on the computer, or the occasional post to Youtube for unlisted distribution.

    I (perhaps mistakenly) think there should be a basic workflow I can establish to nondestructively convert and archive these vids for backup and later use. I just can't quite figure out what it is.

    BTW, the list has already been pared down.

    Thanks for reading this far...
  2. MacUser2525 macrumors 68000


    Mar 17, 2007
    A quick search says that the .mod extension is just that an extension the files themselves are standard mpeg files with non-standard extension. As such a simple rename will get you a standard video file as is stated in the links below. Those programs you mention are all converters and will result in loss of quality you may not find acceptable. Option 1 try a rename to .mpeg to see if the playback is not messed up to a 4:3 aspect with a correct extension. If it is then option 2 ffmpeg to change the container setting the aspect ratio to what it really is something like this for the command line in Terminal.

    /path/to/ffmpeg -i file.mod -acodec copy -vcodec copy -aspect 16:9 file.mpeg
    You can use just about any extension/container you want .mp4, .mkv, .avi .. anything supported by ffmpeg of course using the correct aspect for your files in that setting.

  3. T Coma thread starter macrumors 6502

    T Coma

    Dec 3, 2015
    People's Republic of Chicago
    Thanks for the help. I neglected to mention that I have tried the extension change trick before. But for this discussion, I tried it again, from .MOD to .MPEG. Strangely, the interlacing effect disappears, but the clarity seems to be less, i.e., it's a bit blurrier.

    Next, I tried your ffmpeg terminal command, and the resulting file did NOT change aspect, but the interlacing effect disappears, but the initial clarity/sharpness of the MOD file remains. FYI, here's the report:

    ~ TComa$ /location/ffmpeg -i /location/mov001.mod -acodec copy -vcodec copy -aspect 16:9 mov001.mpeg

    ffmpeg version 2.8.6 Copyright (c) 2000-2016 the FFmpeg developers

    built with llvm-gcc 4.2.1 (LLVM build 2336.11.00)

    configuration: --prefix=/Volumes/Ramdisk/sw --enable-gpl --enable-pthreads --enable-version3 --enable-libspeex --enable-libvpx --disable-decoder=libvpx --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-avfilter --enable-libopencore_amrwb --enable-libopencore_amrnb --enable-filters --enable-libgsm --enable-libvidstab --enable-libx265 --disable-doc --arch=x86_64 --enable-runtime-cpudetect

    libavutil 54. 31.100 / 54. 31.100

    libavcodec 56. 60.100 / 56. 60.100

    libavformat 56. 40.101 / 56. 40.101

    libavdevice 56. 4.100 / 56. 4.100

    libavfilter 5. 40.101 / 5. 40.101

    libswscale 3. 1.101 / 3. 1.101

    libswresample 1. 2.101 / 1. 2.101

    libpostproc 53. 3.100 / 53. 3.100

    Input #0, mpeg, from '/Users/TComa/location/mov001.mod':

    Duration: 00:05:16.82, start: 0.255589, bitrate: 4875 kb/s

    Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p(tv, smpte170m), 704x480 [SAR 10:11 DAR 4:3], max. 9542 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc

    Stream #0:1[0x80]: Audio: ac3, 48000 Hz, stereo, fltp, 256 kb/s

    Overriding aspect ratio with stream copy may produce invalid files

    [mpeg @ 0x7fdcf5821200] ac3 in MPEG-1 system streams is not widely supported, consider using the vob or the dvd muxer to force a MPEG-2 program stream.

    Output #0, mpeg, to 'mov001.mpeg':


    encoder : Lavf56.40.101

    Stream #0:0: Video: mpeg2video, yuv420p, 704x480 [SAR 40:33 DAR 16:9], q=2-31, max. 9542 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 29.97 tbc

    Stream #0:1: Audio: ac3, 48000 Hz, stereo, 256 kb/s

    Stream mapping:

    Stream #0:0 -> #0:0 (copy)

    Stream #0:1 -> #0:1 (copy)

    Press [q] to stop, [?] for help

    frame= 3706 fps=0.0 q=-1.0 size= 73228kB time=00:02:03.62 bitrate=4852.5kbits/frame= 7383 fps=7365 q=-1.0 size= 144084kB time=00:04:06.31 bitrate=4792.0kbitsframe= 9495 fps=7273 q=-1.0 Lsize= 184214kB time=00:05:16.83 bitrate=4763.0kbits/s

    video:173457kB audio:9901kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.466945%
  4. MacUser2525 macrumors 68000


    Mar 17, 2007
    Aspect ratio was not needed to be changed anyways that 704x480 [SAR 10:11 DAR 4:3] is a 4:3 aspect ratio file so ffmpeg did the correct thing by not changing it. Not sure where you want to go with this let me know what you are thinking. There are other programs like Avidemux which will do what you just did with ffmpeg graphically or Handbrake even which you mentioned now I think on it more in its Picture option has setting in there you can turn on for de-interlacing if wanting to use it for conversion to lower bitrate file(s).
  5. T Coma, Feb 18, 2016
    Last edited: Feb 18, 2016

    T Coma thread starter macrumors 6502

    T Coma

    Dec 3, 2015
    People's Republic of Chicago
    Aspect absolutely needs to be changed; there is no doubt it is narrower than it should be. I'm not exactly sure how 704:480 is the same as 4:3. The video is definitely supposed to be 16:9. I have corrected it with I believe handbrake in past, but there is also a certain loss of quality. Something is getting tweaked (or not tweaked) so the picture is off, as you can see below, complete with interlacing effect.


    Still researching...

    EDIT: I see... anamorphic PAR. Interesting. More research needed.

    EDIT2: I forgot to mention - iMovie imports the videos in the correct, unsquished aspect ratio, albeit with a rough deinterlace job.

    --- Post Merged, Feb 18, 2016 ---
    Ok, I hope I got this cracked. Here is an otherwise unedited version of a random vid from 2008 recorded with the Panasonic, as per the ffmpeg details above, and if I read it right, PAR width 10, PAR height 11...

    This is the same vid with PAR width set to 32 and PAR height set to 27 (I think) - and an interlace filter, maybe a bit too much though.

  6. MacUser2525 macrumors 68000


    Mar 17, 2007
    Yes I can see what you mean those are definitely 16:9 from the looks of them. Depending on how you want the end video ie. compressed (transcoded) or not looks like you will have to keep playing with it in the various programs until you get the desired result. The good thing is the video looks crisp and clear so if you do transcode for smaller file size it should end up close to the same.
  7. orph macrumors 68000


    Dec 12, 2005
    1 have you looked at the video camera manual it might help, sounds like you incorrectly imported the files.
    you may be able to fix it in quick time 7 in the properties tab
    2 when you say archive what do you mean? why not just burn them to dvd's? (as data)
    3 you can play them in vlc, in vlc go to -> video -> aspect ration and change it till it looks right to play them

    do you relay want to de-interlace ? what is the desired playback device if it's a dvd player as a dvd video it will get re-interlaced

Share This Page