Time wrong whenever the computer starts

LoneWolf121188

macrumors 6502a
Original poster
Jun 7, 2007
666
0
Longmont, CO
For some reason, whenever OSX starts up (from a reboot, not just standby), the time is always wrong. As soon as I click Open Date & Time, it fixes itself, but its just kinda annoying. Can anyone clue me in to why this is happening?

10.4.10, btw
 

wordmunger

macrumors 603
Sep 3, 2003
5,125
2
North Carolina
That's usually an indicator of a battery problem. But in a macbook pro I don't think that would be it. You could try removing your battery and reseating it. That might do the trick.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
16,781
1,065
Are you also running Windows via Boot Camp? There have been some clock issues going back and forth between the two.

What kind of machine is it? If it's a laptop, it could be an issue with your PRAM battery or maybe something as simple as needing to reset the SMC.
 

Sam*

macrumors regular
Feb 14, 2006
204
0
UK
yeah, i have this problem when switiching back from bootcamp

i must say, its a bit annoying really
 

DoFoT9

macrumors P6
Jun 11, 2007
17,532
31
Singapore
yeah, i have this problem when switiching back from bootcamp

i must say, its a bit annoying really
yea i think every user has this issue. do u have the newest BC 1.4 or still running on 1.3?? it has something to do with M$ not being able to do something properly. im not entirely sure..
 

LoneWolf121188

macrumors 6502a
Original poster
Jun 7, 2007
666
0
Longmont, CO
Its not a battery issue, because I have this problem while its plugged in (it usually is). Probably boot camp. I'm running 1.3. Any reason to update to 1.4?
 

awmazz

macrumors 65816
Jul 4, 2007
1,100
0
Not the main Macbook battery, but the small lithium PRAM battery. The date and time playing up is usually the first indication it's going flat and needs replacing.

When it goes completely flat the date reverts to either Aug 27th 1956, the birthday of Ray Montagne who designed the CUDA microcontroller in Macs, or it reverts to 'zero year' which is Jan 1 1904 (chosen as the starting year because 1900 wasn't a leap year).
 

Mechcozmo

macrumors 603
Jul 17, 2004
5,215
2
Not the main Macbook battery, but the small lithium PRAM battery. The date and time playing up is usually the first indication it's going flat and needs replacing.

When it goes completely flat the date reverts to either Aug 27th 1956, the birthday of Ray Montagne who designed the CUDA microcontroller in Macs, or it reverts to 'zero year' which is Jan 1 1904 (chosen as the starting year because 1900 wasn't a leap year).
The first part is true, the second part isn't. If you're running OS X, the computer will set the clock to the UNIX epoch, or January 1st, 1960 GMT. (But depending on the time zone you're in, you can be earlier than it.)

Old World Macs would default to January 1st 1904 and count the seconds from that time... which is why in about the year 3001, your Mac 128K will run out of memory to hold such a large number of seconds, and roll over, causing the end of the world due to the Y3K bug!
 

awmazz

macrumors 65816
Jul 4, 2007
1,100
0
The first part is true, the second part isn't. If you're running OS X, the computer will set the clock to the UNIX epoch, or January 1st, 1960 GMT. (But depending on the time zone you're in, you can be earlier than it.)

Old World Macs would default to January 1st 1904 and count the seconds from that time... which is why in about the year 3001, your Mac 128K will run out of memory to hold such a large number of seconds, and roll over, causing the end of the world due to the Y3K bug!
LOL!

Thanks for the info. I was totally unaware of the new UNIX default date. I guess I didn't pay attention to the date the last time my battery needed replacing!
 

Mechcozmo

macrumors 603
Jul 17, 2004
5,215
2
LOL!

Thanks for the info. I was totally unaware of the new UNIX default date. I guess I didn't pay attention to the date the last time my battery needed replacing!
Well, it isn't exactly a "new" UNIX date... it's been around for awhile.

When did you last have to change your PRAM battery? You shouldn't have to, unless you left it alone for quite some time without battery or AC power. (Some time over 6 months might do it)
 

awmazz

macrumors 65816
Jul 4, 2007
1,100
0
Just 'new' to me as I've just learned it from you, even though UNIX has been around for decades.

Actually changed the battery a few months ago in my 2002 G4 MDD so I must have actually seen the UNIX default date was different, but I guess I just didn't pay attention to it. I've replaced a lot of batteries recently in my classic Mac collection so those default dates have stuck in my mind.
 

woody51593

macrumors newbie
Apr 19, 2008
2
0
I am having the same problem with my clock's being wrong

I have a new MacBook Pro and I'm running Leppard and also the newest vista home and every time I boot the vista the clock is about 7 hours ahead. If anyone can help me figure this out and what I need to do to fix it would be a great help.
 

Trip.Tucker

Guest
Mar 13, 2008
945
1
The first part is true, the second part isn't. If you're running OS X, the computer will set the clock to the UNIX epoch, or January 1st, 1960 GMT. (But depending on the time zone you're in, you can be earlier than it.)

Old World Macs would default to January 1st 1904 and count the seconds from that time... which is why in about the year 3001, your Mac 128K will run out of memory to hold such a large number of seconds, and roll over, causing the end of the world due to the Y3K bug!
Wow, delightful story but not even close. The problem is that Windows has no real default support for UTC. There is a fix however:

In Windows, set the following dword key value to 1:
HKEY_LOCAL_MACHINE_SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
 

woody51593

macrumors newbie
Apr 19, 2008
2
0
I did this and it is working

Great tip, I have a macbook pro running Mac OS and windows vista home.
I did this and it has worked so far.
In Windows, set the following dword key value to 1:
HKEY_LOCAL_MACHINE_SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
I did have to turn off the auto internet time update in the windows OS though witch is fine with me because when I boot in mac OS it is on and updates it then.
 

peterlobl

macrumors regular
Jun 26, 2007
140
3
Philadelphia
Great tip, I have a macbook pro running Mac OS and windows vista home.
I did this and it has worked so far.
In Windows, set the following dword key value to 1:
HKEY_LOCAL_MACHINE_SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
In XP I created the DWORD in the registry... (does it already exist in Vista?)

The directory is slightly different it seems --

HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal


Don't have Vista here, will see if it works - thanks much for the tip!