TimeCapsule NAS problem with Windows 7

Discussion in 'Mac Accessories' started by Plain Lazy, Nov 24, 2009.

  1. Plain Lazy macrumors newbie

    Nov 24, 2009
    Hi Guys,

    first post on MR, so please be gentle...

    Post is as the title says - I'm having problems using the NAS features of the TC once my other half’s laptop was upgraded to Windows 7. The TC is a first gen DualBand. It was working perfectly OK using windows vista home premium, and continues to work perfectly on snow leopard on my Mac.

    The problem is that access to the drive is REALLY flaky. I was eventually able to map the TC drive within windows, but copying files to the TC, or even browsing the TC errors out at random times, but mostly during the start of a filecopy.

    I have tried lots of things so far:

    1. Changed the registry key for "LmCompatibilityLevel" as discussed in http://technet.microsoft.com/en-us/library/cc960646.aspx - this does the same as the group policy editor changes which aren’t available to windows 7 home prem users. This allowed me to actually map the TC share - but gave the same access problems.

    2. Tried mapping the share using "net use" at cmd level, by mapping via explorer and by browsing via UNC sharename. All showed the same problems.

    3. Tried downgrading the firmware to 7.3.x - unfortunately this isn't possible as the DualBand TC base firmware cannot be below 7.4. Problem still exists on 7.4 and 7.4.1. Firmware 7.5 exists, but just for DualBand MiMo TC owners.

    4. Tried both windows 7 home premium 32 and 64 bit, same problem.

    5. Tried different WiFi drivers (MS WHQL and Intel WHQL). Same problems.

    Anybody got anything different to try? I've run out of ideas. Its becoming a real pain now, as it defeats the object of having a NAS that only 1 machine can access.

    Thanks for reading.
  2. DanielCalladine macrumors member

    Jul 19, 2008

    Sorry I can't offer any advice but I have been experiencing the same problems, perfect on Vista but won't work on Windows 7.

    It normally causes my girlfriends Dell to blue screen when accessing the TimeCapsule or its attached Airdisk.

    It's the Sim Dual Band TimeCapsule and a new Dell with Window 7 Professional.

    I came across your post while searching for a solution.

    Hopefully someone's got an answer, Cheers, Daniel
  3. strathmore macrumors newbie

    Dec 24, 2009
    Hi, there
    I'm suffering from the same problem with Windows 7 and AiportExtreme / Airdisk. :(
    No problems with XP or OS 10.5 / 10.6
    Virtual Windows 7 with VM-Ware Fusion 3 under Snow-Leopard as well as Hardware Windows 7 on MSI-Wind Netbook.
  4. Plain Lazy thread starter macrumors newbie

    Nov 24, 2009
  5. tenderidol macrumors regular


    Sep 5, 2009
    I'll be damned! I turned off "Windows Search" and restarted the computer. I have been moving files back and forth (sizes ranging from 10KB to 1.2GB) between the desktop and TC and it's working fine. I dont want to jinx it, but if it works like this it's great!

    By the way, I am using the most recent refresh of the 2TB TC (firmware 7.5 I believe) and Windows 7 Pro 64 bit. I didn't "map the TC". I am just opening it from My Computer and so far it works. I'll schedule some backups now to see if Windows is able to access and use the TC as a back up drive. We'll see...

  6. DanielCalladine macrumors member

    Jul 19, 2008
    Thanks tenderidol,

    That has seemed to have fixed it for me also!

    Is there anyway of only excluding Windows Search from the Time Capsule or does it have to be disabled for everything?

    Now all I have to do is to find out how to backup to a network drive again since Microsoft has removed it from the Home Premium version!

    Thanks again, Daniel
  7. greezychicken macrumors member

    Apr 23, 2005
    I'm also having problems with this with an Airport Extreme (non-dual band) and Windows 7 Home 64 bit. I've tried disabling Windows Search and the LmCompatibility registry hack and they didn't work. Downgrading my AE firmware to 7.3.2 seemed to help with the problem but then my internet would lockup whenever my Macbook Pro (10.6.3) fired up a Time Machine backup.

    Both external drives (the one Windows 7 keeps failing on file copy to and the Time Machine drive) are hooked up as Airdisks to the Airport Extreme.

Share This Page