TimeMachine - "Back Up Disc Not Available"

Discussion in 'macOS' started by yOGi420™, Sep 19, 2009.

  1. yOGi420™ macrumors member


    Feb 5, 2009
    Central Cali
    I have been using a MyBook WD 1TB drive connected to my AirPort Extreme for my TimeMachine back up disc. I have noticed that it has not been backing up recently so I made sure to open open the drive and have it mounted to my desktop then clicked "Back Up Now" on the TM pull down menu, it said "Preparing Backup" in the TM Pref screen then came back with the notification "The backup disc is not available" even though I know it should be since the icon is on my desktop. The only change I have made recently is updating my system to Snow Leopard but I'm not sure exactly if that was when my back ups stopped. Can anyone help me with this issue I'm having?????
  2. rices89turbo macrumors newbie

    Oct 22, 2009
    snow leopard back up disk not available

    i am having the same problem. local backups(usb) work fine but not network backups. not sure if this has anything to do with it but to get the original leopard OS to see my network drive on my airport extreme i had to run this command in terminal:

    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

    any help would be awesome.
  3. puma1552 macrumors 601

    Nov 20, 2008
    As of October 23rd I'm having this same problem, telling me "Back up disc not available" and then telling me "Connection failed", saying there was an error connecting to the server.

    This worked just fine before, and nothing has been updated in the past few days.

  4. quihana macrumors newbie

    Nov 1, 2009
    Backup disk not available

    Following a tip elsewhere, I deleted the com.apple.TimeMachine.plist in the system Library, and restarted, which prompted Time Machine to ask what disk to use. All went smoothly from there. All my old backups are still in place and viable.
  5. milou macrumors newbie

    Jan 15, 2010
    i fixed it in the control panel

    i had the same error, but i just clicked the "choose disk" button in the TM control panel, and chose the same disk again. magically, the disk icon changed back to the green TM disk icon and it happily started backing up.
  6. techcafe macrumors member

    Nov 27, 2009
    gorgeous looking hunk of junk... at this point

    exact SAME issue here.

    Time Machine reports: Preparing backup... but then generates an error (after some time), stating The backup disk is not available (even though i can access it no problem via the Finder).

    i just got my 2TB Capsule, and i have to say, i am quite disappointed so far. Windows 7 clients cannot maintain a reliable connection to the NAS (there are constant SMB timeouts/disconnects). the Capsule's NAS is essentially useless with Win7 clients.

    and then Mac OSX Time Machine apparently 'forgets' where the TimeCapsule drive is located or can't find it for whatever reason. so, as it is right now, the NAS feature of the Time Capsule is an epic failure, completely unreliable at this point.

    and to think i returned my AirPort Extreme (also recently purchased) and replaced it with the Time Capsule, wrong assuming that it would perform better AND reliably. turns out i was sadly mistaken.

    so, there's $600 down the drain. thanks Apple! :mad:

    Apple better release a firmware update SOON to FIX these glaring technical problems.
    update: i may have discovered WHY the Time Machine generates the 'backup disk not available' error.

    i changed the default Time Capsule Name (via the AirPort Utility) to 'TimeCapsule', and that is when the problems with Time Machine backups began. re-selecting the newly configured Time Capsule name (via Time Machine preferences, Select Disk button) does not fix the issue.

    only after renaming the Time Capsule back to its original name (when the Time Machine was initially configured to use the Time Capsule for backups), was the problem resolved. so now the Time Machine is doing backups to the Time Capsule again - after restoring the Time Capsule's old network name.

    so, if your Time Machine suddenly can't find the Time Capsule NAS anymore, then maybe you've modified the Time Capsule Name. change it back to what it was and backups should (may?) start working again.

    Windows 7 clients still can't establish a reliable connection to the TC NAS, at all. WinXP clients seem to be unaffected by the unstable NAS, however, the System Event Log on the XP client shows a lot of MRxSmb errors (redirector failed to determine the connection type), whenever the XP machine connects to the TC NAS. so there are definitely NAS issues affecting Windows network clients.
  7. tug macrumors 6502

    Feb 3, 2010
    loughborough. u.k.
    dead easy, all you do when getting the b,u,d, not available is turn off the time capsule at the power source wait for a couple of minutes turn back on, wait for light to go green,right click on toolbar icon 'back up now' and thats it!
    best regards to all.
  8. HowEver macrumors 6502a


    May 10, 2005
    This worked for me, no problems after.

  9. penter macrumors 6502a


    Jun 15, 2006
    This did it for me lol
    Silly time machine...
  10. piperdog macrumors newbie

    Jan 1, 2013
    backup disk not available

    sometimes it is the simple things. I unplugged the time capsule. Restarted my MAC. then when I opened time capsule again, it allowed me to select the disk.
    thanks for the advice from the prior post.

Share This Page