Timer set on iPhone not sounding on watch since updates

Discussion in 'Apple Watch' started by Julien, May 16, 2017.

  1. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #1
    Set a timer on my iPhone and left it upstairs (still BT connected) and when the timer ended my :apple:Watch didn't notify me and give me the option to cut off. So I missed the timer and when I went back upstairs it was sounding on my iPhone. Restarted both devices and still not getting it on my :apple:Watch. Could someone who is update on both try setting a 1 minute timer on their iPhone and see if it sounds on their :apple:Watch.
     
  2. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #2
    Julien, I get the same results as you. I also tried restating both the phone and watch as well as turning off and back on the "Push Alerts from iPhone" slider under clock, which is supposed to alert you of timers and Alarms, but still no notifications to the watch
     
  3. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #3
    Must be a bug then. Surprised no beta testers noticed/reported this.
     
  4. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #4
    I didn't, though I generally don't set my timers on the phone, generally always on the watch. Are you going to submit it?
     
  5. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #5
    Just tested a 30 second timer on my iPhone ... as expected, my Watch and my iPhone sounded their respective alerts. FWIW, I am running 10.3.2 on my iPhone, but have not yet updated the watchOS on my Watch - still running v 3.2... it's such a PITA to update watchOS, and don't see anything in 3.2.2 compelling enough to endure the pain of the upgrade.
     
  6. PackyP macrumors member

    PackyP

    Joined:
    Feb 29, 2016
    #6
    My notifications have been all messed up since 3.2 and 3.2.2 hasn't seemed to help. The notifications settings seem to be ignored on certain apps. I get notifications on the watch for the calendar for example, when i have them completely turned off on the phone and I have the watch app set to mirror the phone. Fantastical is the opposite, half the time I don't get notifications on the watch at all even though they are all on for the phone and the watch is set to mirror.


    I have unpaired and re-paired, uninstalled and re-installed apps and it doesn't seem to help. Wish they would get it all straightened out.
     
  7. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #7
    Yes, when I get home. But first will instal 10.3.3b1 and see if that fixes it (I'm an AppleSeed beta tester).
     
  8. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #8
    Cool! Let us know if that does resolve the issue!
     
  9. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #9
    About to do a meeting and will install/try after that.
     
  10. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #10
    I was able to get a break and installed 3.2.3b1, that did not resolve the issue. Trying an unpairing/re-pairing to see if that resolves it.
     
  11. ericg301 macrumors 6502a

    Joined:
    Jun 15, 2010
    #11
    Yes -- this. I've been having the same issue. Glad to see I'm not the only one. I've started a support ticket with Apple.

    I was getting default calendar and reminder app alerts on my watch even though they're turned off on my phone and watch is set to "mirror my phone." I use Fantistical for both instead.
     
  12. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #12
    Same for me too. Post after re-paring.
     
  13. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #13

    I tried re-pairing restoring the watch from a backup, but no joy. I wonder if I should try again setting up as new?
     
  14. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #14
    So, on IOS 10.3.3b1 and Watch OS 3.2.3b1, have unpaired and re-paired the watch from a back and then un-paired and set up as new. None of that seems to have worked. Was this behavior changed by design for some reason?
     
  15. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #15
    3.2.2 on OG watch.
    Set timer for 2 minutes on my phone. Rings on both the phone and watch.
     
  16. kevo0822 macrumors regular

    Joined:
    Jul 13, 2007
    Location:
    New England
    #16
    Literally just a minute ago, I was sitting at my desk thinking "I've really been bad at noticing the vibration notifications on my watch tonight." I'm glad it's not just me!
     
  17. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #17
    What iOS are you running?
     
  18. matrix07, May 17, 2017
    Last edited: May 17, 2017

    matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #18
    10.3.1

    Out of curiosity I also updated to 10.3.2 and it still rings on both phone and watch.
     
  19. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #19
    Strange that mine is now working. Oddly the only thing I did (which is probably NOT related) is open the Home app. Tried Siri to adjust my thermostat and it keep saying device not found on my :apple:Watch but worked on my iPhone. So I opened the Home app on my iPhone and then Home (Siri/thermostat) started back working on my :apple:Watch. The next time I set a timer on my iPhone it went off on my :apple:Watch too. Probably a coincidence but worth a try.
     
  20. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #20
    Hmm. I couldn't adjust my thermostat because it is a Nest and does not work with the Home App, but I did lock and unlock my Schlage Sense front door lock and nothing changed. Not sure what is up with it. I never really use the function, but it still annoys me that it doesn't work as it should hahaha.

    Edit: Actually if I have Siri set the timer for 1 minute it works, if I set it manually it does not.
     
  21. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #21
    Works for me both by the app itself and SIRI.
     
  22. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #22
    I believe what the issue is was that the phone was not locking prior to the timer sounding, particularly if a notification came in during that 1 minute, due to the fact I had Auto-Lock set to 1 minute.

    I believe the phone has to be locked or the app has to be in the background as it is when starting from Siri. Setting auto-lock to 30 seconds, the phone locks, and the 1-minute timer works on both the watch and the phone.

    Likewise, if I set Auto-Lock back to 1 minute, but set the timer for 2 minutes, it sounds both on the phone and the watch.
     
  23. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #23
    Good find!
     
  24. warburg, May 20, 2017
    Last edited: May 20, 2017

    warburg macrumors 6502

    Joined:
    Jul 27, 2008
    #24
    This thread has me quite confused. I'm running 3.2.2 on my AW, but when I set the timer on my iPhone and it ends, I do not get a signal on the AW? Am I supposed to? If so, is there anything I have to do in settings on either the phone or the watch to assure that this happens?
     
  25. SDColorado macrumors 65816

    SDColorado

    Joined:
    Nov 6, 2011
    Location:
    Highlands Ranch, CO
    #25

    On your phone you want to open the Watch App and choose Notifications->Clock->Push Alerts from iPhone (when this is on, Apple Watch will notify you of Timers and Alarms you've set on your iPhone, so that you can snooze or dismiss them remotely).

    I have also found that the timer needs to be running in the background, as it does with Siri, or the phone needs to time-out/sleep, otherwise, it will only sound on the phone. This was the problem I was running into with a 1 minute time and also to Autolock at 1 minute. Settings->Display & Brightness->Autolock. If the phone did not auto-lock, within that 1 minute, I found the timer only sounded on the phone. But if I set that to 30 seconds, set the timer to more than 1 minute, or manually locked the phone, it sounded on both the phone and the watch.

    My issue was simply one of a conflict with a one-minute timer and 1-minute auto-lock and sometimes notifications being received causing it to lock later than the alarm.
     

Share This Page