iPhone Tiny Umbrella not recognising my devices!

Discussion in 'Jailbreaks and iOS Hacks' started by Mezzor, Feb 4, 2013.

  1. Mezzor macrumors newbie

    Joined:
    Jul 28, 2010
    #1
    OK so I have an iPhone 5 and Ipad (4th gen) on 6.1 ready to jailbrake when it's released shortly. I have never done this before and have read that you must save the blobs SHSH or something like that.. Anyway, I have downloaded tinyumbrella and bo0ted it up but it wil not recognise either one of my devices.

    Things I've tried:

    Firewall off
    Updated Java
    Re-installed itunes
    downloaded and tested an old version of TU

    Still nothing

    Any help is appreciated.
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    latetst version 6.10.02a which should work fine on your devices.

    does itunes recognize your devices?
     
  3. dinggus macrumors 65816

    Joined:
    Jan 17, 2012
    #3
    Just so you know, you don't need your devices plugged in to save SHSH.

    On the left column, click SHOW ALL SHSHS.
    On the right, click Save All SHSHs

    There you go.

    TinyUmbrella is just a way to help restore a firmware that isn't being signed anymore. That is when it'll need to recognize your devices.
     
  4. lapeno macrumors 6502

    Joined:
    Jul 26, 2010
    #4
    Encountered similar problem.

    Used a friend's laptop and was able to save the shsh from tinyumbrella.
     
  5. Mezzor thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #5
    Yes iTunes recognizes them fine. And I have the latest TU too.


    Also yes I know but when I click that button (Save all SHSHs), nothing happens.

    Here is a copy of the log

    Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\iTunesMobileDevice.dll: The specified procedure could not be found
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(Unknown Source)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at com.semaphore.jna.LibraryFinder.findMobileLibrary(LibraryFinder.java:130)
    at com.semaphore.jna.LibraryFinder.foundMobileLibrary(LibraryFinder.java:110)
    at com.semaphore.jna.LibraryFinder.getMDLibrary(LibraryFinder.java:68)
    at com.semaphore.jna.LibraryFinder.<clinit>(LibraryFinder.java:28)
    at com.semaphore.jna.md.MDLibrary.<clinit>(MDLibrary.java:21)
    at com.semaphore.jna.idevice.win.WinDeviceLibrary.addNotificationHandler(WinDeviceLibrary.java:43)
    at com.semaphore.service.DeviceListenerService.run(DeviceListenerService.java:60)
    at java.lang.Thread.run(Unknown Source)
    TinyUmbrella[INFO|AWT-EventQueue-0|11:15:48]: Trying to enable TSS...
    Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\iTunesMobileDevice.dll: The specified procedure could not be found
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Anti-virus or firewall problem, disable them or try redsn0w to save your blobs
     
  7. Mezzor thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #7
    But I've disabled all Anti V and turned off the firewall so how can it be?
     
  8. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    Depends on your particular setup, sometimes happens on PC's

    Use redsn0w
     
  9. Mezzor thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #9
    On Redsnow I get the error "Couldn't load MobileDevice.dll (Error 127)?
     

Share This Page