Tired Of This!

Discussion in 'MacBook Pro' started by zeiter, Dec 7, 2008.

  1. zeiter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #1
    Hello there,

    I am writing again because I cannot stand this anymore. I went to pick up another monitor to test the text appearance on a new monitor to see if it was my samsung or my dvi cable...do not worry, I will get reimbursed. It does the same thing so I am thinking it might be my videocard or something.

    For example, when I am chatting in skype and I do this " !!!! ", not all the ! have the same black and two of them look washed away. It happens to a lot of letters when I write things...It is annoying when you try to read or write something in word.

    So, my question is, what do you think could be the source problem. Could it be my video out? or is this supposed to be another crap thing I must endure as a new mac user because macs prefer it to look like it is print or do we have to buy their $600 screen to get perfect text appearance...well actually, when I print my text, all letters have the same black level. Sorry, but I am tired and pretty pissed about this...

    Thank you everybody

    EDIT: it does the same thing on my macbook pro when used without an external display. I was wondering if this is normal or my video card is messed up. thank you!
     
  2. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
  3. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #3
    Could it be the font or program you are typing in? I have found that certain apps (poorly coded usually) display random characters a little off from what they should be.
     
  4. six.four macrumors 6502

    Joined:
    Oct 24, 2008
    #4
    A picture is worth 1000 words.

    It'd be easier to help if you had a picture or a screenshot or something.
     
  5. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #5
    It's kind of hard...because your monitor will actually see it as alright no? I noticed that the bigger the font is, the problem is less present!
     
  6. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #6
    No. If there's an issue, unless it's your monitor, it will most likely show up in the screenshot.
     
  7. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #7
    ok let me take one..
     
  8. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
  9. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #9
    Your screenshot shows JPG artefact and thus doesn't help that much. ;) Try using PNG please.

    What you experience is most likely just Apple's equivalent of "Cleartype" aka Font smoothing (no idea how Apple actually calls it). It uses the RGB subpixels of your screen to display fonts at a virtually higher horizontal resolution.

    To make it visible keep CTRL pressed and use the two-finger swipe upwards to zoom in. You will notice red coloring on the left side of fonts and blue on the right side. At native resolution and without zooming the eyes wont notice the colors anymore and thus the effective horizontal resolution is nearly trippled.

    Some fonts are not so suitable for this kind of "effect" so I advice you to set another font in those applications where it bugs you most. Bigger fonts are also less prone to problems because only the edges are affected, which obviously makes a bigger part with small fonts.

    It may also be that your application does not use this font smoothing technique but rather only uses grey pixels to do the smoothing. While that looks good on big fonts, it usually degrades small fonts readability considerably.

    You can change the smoothing method and minimum font size that smoothing is used on via the Appearance Settings! (german version here, so I hope I found the correct translation).
     
  10. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #10
    Here is the .png version

    [​IMG]


    So, you are telling me everyone is experimenting the same thing as me and it doesn't bother them and everything? Look, even in writing with office, I have to change the font to all my programs...isn't it kind of stupid and ridiculous?
     
  11. MH01 macrumors G4

    MH01

    Joined:
    Feb 11, 2008
    #11
    Took me a while to see what the problem was.

    I just tried !!!!!!!!!!!! on a dell monitor, same thing. But at high resolutions. I think you will find the same problem if you use high rez on any monitor. This is probably more of an issue with LCD and native resolutions.

    If it really concerns you, go to a Apple shop and try it on a few monitors.
     
  12. bobfitz14 macrumors 65816

    bobfitz14

    Joined:
    Oct 14, 2008
    Location:
    Massachusetts
    #12
    i don't like your screenname :p and i've never seen spanish words spelled like that?
     
  13. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #13
    well on my windows box, everything is fine...so this is a mac os x issue or what?
     
  14. MH01 macrumors G4

    MH01

    Joined:
    Feb 11, 2008
    #14
    In that case, if the res was the same. Could be the display card. Likely a driver issue. Not sure you will get a quick fix to this
     
  15. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #15
    well, I tried 2 different monitors and dvi cables it it is the same, even in my internal macbook pro display. It is quite annoying.
     
  16. Sorkvild macrumors 6502

    Joined:
    Feb 23, 2007
    #16
    heres my string of !s.

    Pretty sure Timur's explanation is spot on.
     

    Attached Files:

  17. chaosbunny macrumors 68000

    chaosbunny

    Joined:
    Mar 11, 2005
    Location:
    down to earth, far away from any clouds
    #17
    Have you tried typing the "!!!!!!" in a different program? I just tried it in TextEdit on both my iMac (+ external screen) and my mbp, and they all look the same.
     
  18. NoNameBrand macrumors 6502

    Joined:
    Nov 17, 2005
    Location:
    Halifax, Canada
    #18
    Mac and Windows use different techniques for font antialiasing. Ever notice that the text in the Windows versions of Apple's apps looks off, somehow? It's because Apple ported their rendering system and used that instead of the native one. The flip side is that most Mac users despair at the way fonts are rendered in Windows. :p

    You can control font antialiasing in System Preferences (Appearance section). There's several levels, and you can disable it for small fonts.
     
  19. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #19
    you guys don't find it pretty annoying? Seriously?
     
  20. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #20
    Didn't I say that already?! ;)

    No one seems to have tried that yet. But I tried myself quickly and oddly couldn't notice a difference. I suspect that you need to log off for the changes to happen, but I did not mess with it enough yet (need to get Windows running for audio-performance on my MBP first).
     
  21. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #21
    seriously dude, i cannot stand it. I wonder what I will do. :( everything was so cool then this pain the "beep" problem appeared :(
     
  22. chaosbunny macrumors 68000

    chaosbunny

    Joined:
    Mar 11, 2005
    Location:
    down to earth, far away from any clouds
    #22
    Did you even try Timurs suggestion? I would guess he is right and you need to restart (or relog) after you apply changes to take effect.
     
  23. zeiter thread starter macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Canada
    #23
    yes I did and nothing changed and yes I rebooted
     
  24. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #24
    Sounds like a bug then, the settings should have at least some effect. Let's report to Apple and have it fixed. :)
     
  25. evanxlee macrumors newbie

    Joined:
    Dec 4, 2008
    #25
    my powerbook does the same thing,

    it's not a problem! it's not the OS, it's not your GPU, it's not the polarity of the earth shifting; it's not anything having to do with your computer. some character spacings aren't going to line up with the pixels on your display. that's all it is. take a print course and you'll learn about leading and kerning. the font characters are spaced according to the parameters of the font, and the GPU will display them where they belong. if it doesn't line up perfectly with your display's pixels (which it NEVER will), you'll get that weird "thin-thick/slanty/blurred" kind of effect.

    just enjoy it !!!!!

    (yep, mine did it there too!)
     

Share This Page