TM instead off @

Discussion in 'macOS' started by HeroBiX, Nov 3, 2012.

  1. HeroBiX, Nov 3, 2012
    Last edited: Nov 3, 2012

    HeroBiX macrumors member

    Jan 8, 2010
    I just started my new MacBook Pro, I been using Mac for around six years now, why I say that is this is really strange

    When I press "ALT + 2" I get the "TM" symbol instead of "@", which gets really enjoying, I'm using Swedish keyboard and on my old MacBook which is on 10.5 works perfectly fine with getting "@" with "ALT + 2" and I have also tried all different keyboard combinations

    when I use Canadian keyboard, my @ works, but now I can't make " instead, how can I kill the TM?

    I found out that I need to press "ALT + *" to get "@", but... how can I change this? it's really annoying having a complete different key combination, how can I change it?
  2. shurcooL macrumors 6502a

    Jan 24, 2011
    Is there a reason you don't want to use the standard shortcut Shift + 2 to get "@"?
  3. meme1255 macrumors 6502a

    Jul 15, 2012
    Czech Republic
    Alt + 2 is standard for non-English keyboard (Czech at least, Swedish too probably )
  4. Andrk macrumors newbie


    Jul 4, 2016
    Stockholm, Sweden
    Hi, so this is much simpler than one might think - there are sever versions of a language in the system preferences, keyboard input menu. Choose Swedish for instance, but make sure you choose Swedish PRO (then it ends up in the right place).

  5. KevKar, Jun 16, 2017
    Last edited by a moderator: Jun 16, 2017

    KevKar macrumors newbie


    Jun 16, 2017
    Thanks so much Andrk! I had the same issue, which drove me crazy for three days, looking for the cause. So you provided the solution! But the question still remains about the cause.. Why did this suddenly happen? I have been using the Macbook for more than a year.. What can change these settings, if the user doesn't?
  6. 1Mei9 macrumors newbie


    Nov 4, 2018
    But where is the Swedish Pro. I could not find out it.
    --- Post Merged, Nov 4, 2018 ---
    Hi, It has made me mad for 1 year. I just don't know how to type @ .unitil 10 minutes ago I decided to solve the problem. How shame ... Anyway, thank you so much. And, I registered to express my gratefulness.

Share This Page