TMobile iPhone can't receive pictures

Discussion in 'iPhone Tips, Help and Troubleshooting' started by KBenton, Dec 1, 2009.

  1. KBenton macrumors member

    Joined:
    Jun 20, 2008
    #1
    I have an iPhone 3G updated to 3.0 and has been for quite some time now. I could receive picture messages just fine until about a month or two ago. I believe i stopped receiving them after TMobile went down that one day.

    I can still send them fine, but when I get a message it says
    "The media content was not included due to a picture resolution or message size restriction"

    Any help would be greatly appreciated!
     
  2. bspcalvin macrumors newbie

    Joined:
    Dec 29, 2009
    #2
    I'm also having this issue. I just placed our iPhone's on TMobile and we get that same message when someone sends a picture. We can receive them when sent from an iPhone but not from another phone. Anyone have a solution or suggestion??
     
  3. zahi745 macrumors newbie

    Joined:
    Jul 14, 2009
    Location:
    Chicago
    #3
    Really?

    Bought a factory unlocked iPhone 3GS and when I updated to the time when AT&T announced picture message I never got that icon when txting? Inguess it's cool to have but have never used it. I use tmobile btw
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Try installing the legacy mms package thru cydia.
     
  5. fullmanfullninj macrumors regular

    Joined:
    Dec 30, 2009
    #5
    I had this problem too, along with many Tmo users...
    This is the fix that worked for me:

    Open Cydia and search for "Legacy" and install the first TMobile one.
    Then reset network settings (Settings -> General -> Reset -> Reset Network Settings).

    I rebooted at this point...I've heard of people just skipping a reboot.

    Go into Cellular Data Network (Settings -> General -> Network -> Cell. Data Network). Enter the following.

    Cellular Data:
    APN: wap.voicestream.com

    MMS:
    APN: wap.voicestream.com
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy: 216.155.165.50:8080

    Optional, but I set MMS Max Message Size to 240000000...found it on a site.

    Press back until you return to Settings. Return home. Reboot. Test with an MMS message to yourself.

    This is what worked for me, hope it works for you :D
     
  6. bspcalvin macrumors newbie

    Joined:
    Dec 29, 2009
    #6
    Thanks. I installed the Cydia software. Then added the 8080 to my proxy setting.......now I get pics.

    Info.... I still have my Cellular Data APN set as epc.tmobile.com while the tmobile tech support had me set only MMS APN to wap.voicestream.com. Will changing the Cell Data APN benefit me?
     

Share This Page