Carrier to enable wifi calling, please contact Tmobile?

Discussion in 'iPhone' started by garyleecn, Sep 16, 2016.

  1. garyleecn macrumors 6502a

    Jul 25, 2014
    so i just moved my old sim card from 6s to new 7+, have never had any problem with wifi calling before.
    however, when i try to enable wifi calling on 7+ it says 'to enable wifi calling, please contact Tmobile'

    anyone having the same problem?
  2. grinny11 macrumors regular

    Aug 12, 2008
    Having the same problem. Read online you should use the sim it came with. Called t-mobile to activate and waited 2 hours. Still didn't work. Spoke to chat and they said they would send something over the air. I've waited about 30 min. still not working.
  3. Zulithe macrumors member


    Jun 6, 2010
    San Francisco, CA
    you're not alone. same issue. i called them, they verified all sorts of things, they said they submitted a report about it but that's it

    wifi calling is a big feature for me, i really need it to get good service at my home, sadly.

    *edit* okay, less than 5 mins later and I think it's working now after they told me they updated something on my account. try rebooting your phone and making sure your icloud restore is 100% completed and if it's still not working, call their support
  4. Sparkeze macrumors 6502a


    Sep 18, 2014
    I moved my son's sim from a 5S to 6+ and got an error message when trying to enable wifi calling. Customer service tried, a T mobile Apple tech guy tried, now we have an engineer ticket. After talking to the tech guy, I wondered if the phone got no info during the 2 hour waiting period because we get no service inside the house. He suggested that we can try to leave the house and have the phone on LTE for a couple hours, then try again and in the meantime they will be looking into it through their end. Obviously, getting no service in the house is why we really need wifi calling but at least it's just my 14 year old's phone!
  5. grinny11 macrumors regular

    Aug 12, 2008
  6. jmann macrumors 604


    Dec 8, 2007
    bump on a log in a hole in the bottom of the sea
    I set mine up using the new SIM card and wifi calling works.
  7. lordofthereef macrumors G5


    Nov 29, 2011
    Boston, MA
    Wife went from 6s to 7. Swapped sins. No issues afaik.
  8. Nde macrumors 6502a


    Feb 12, 2008
    Los Angeles, CA
    No problem here as well. But I did swapped my sim at 11am. And after reading this post, I toggled the wifi calling. It works fine for me. I didn't try earlier, only about 10 hours later.
  9. alldat macrumors regular

    Aug 10, 2008
    Call T-Mobile, don't let them give you the runaround and try stupid fixes. Straight up tell them to de-activate wifi calling on your account, then re-activate it. After that go into the settings on your phone and reset the network settings. After the reboot everything should be fine

    (worked for me after pulling my hair out for an hour trying to fix it)

Share This Page

8 September 16, 2016