Torrent/Transmission Download Question

Discussion in 'Mac Apps and Mac App Store' started by Melrose, Sep 20, 2008.

  1. Melrose macrumors 604

    Melrose

    Joined:
    Dec 12, 2007
    Location:
    In a sidewalk.
    #1
    I'm very new to the whole torrent scene, but this afternoon I'm downloading the first torrent I've ever tried to grab. My question is: The download is being very, very slow (like, between 1 and 14 KB/s) - the Transmission menus says it's only downloaded 48MB, but the folder where all the files are (which I created solely for this torrent) reads 27GB (which is just about the size of the whole torrent - at 31GB). Does this mean that the file system is correct and it's actually downloaded all that? If not, why does it say there's so much there when there isn't?

    Thanks! :)
     
  2. atluten macrumors 6502

    Joined:
    Mar 24, 2008
    #2
    Some types of files sort of "reserve" the space on your HD so when you start the download it'll show all of the space taken by the file, even though you haven't actually downloaded all of it. I am by no means knowledgeable about how this works in particular, but this is how I can best explain it. What Transmission says it had downloaded is how much of the file you have. Cheers.
     
  3. Melrose thread starter macrumors 604

    Melrose

    Joined:
    Dec 12, 2007
    Location:
    In a sidewalk.
    #3
    That's what I was afraid of - Transmission is saying I have between 61 days and 1572 days to go. Niiiiiice.....

    Anywho, thanks for the quick reply. :)
     
  4. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #4
    Slow speed is due to seeders. More seeders generally means faster speed. And transmission does reserve space for the torrent.
     
  5. Melrose thread starter macrumors 604

    Melrose

    Joined:
    Dec 12, 2007
    Location:
    In a sidewalk.
    #5
    Yeah - I checked back on the site and the torrent health is just about zilch. Some sites don't even have any seeders - it's all leeches. They should block leechers it think... If you wanna grab a download, be willing to share.
     
  6. Keytachi macrumors regular

    Joined:
    Sep 14, 2006
    #6
    You might want to chose another port to download from:
    Go to Transmission -> Preferences -> Network and chose a different number (above 25000). Then forward that port in your router (if you use one) and open it in the firewall (again, if you use one). It *should* improve your download speed slightly.
    Also, capping your upload speed helps too, set it to 1/10th of your max upload speed (call your ISP or go to www.speedtest.com with all programs turned off to get the upload speed).

    Hope this helps!
     
  7. Habusho macrumors 6502

    Joined:
    Aug 12, 2006
    #7
    If there are enough seeders, you might have to port forward the port you're using to download. Look up portforwarding on google. That might be the cause of the slow speeds with good amount of seeders.
     
  8. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #8
    What? 32GB? What the heck are you downloading dude?:eek:

    Τhe biggest torrent i have ever downloaded was 3GB!!
     
  9. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #9
    to get fast speeds on torrents (assuming there are lots of seeds) like the speed of your normal downloads you need to open a port for BitTorrent in your router and firewall just like ports are opened for browsing by default. (port 80).

    go to portforward.com, find your router and follow the instructions to open a port in your router and then add that port number to your BitTorrent application and firewall.

    note:
    1. instead of following the instructions for uTorrent just put the port number in Transmission's preferences
    2. you dont need to add the port to OS X's firewall in Leopard the BitTorrent application will just ask you if you want to open connections. in Tiger add a custom entry into your firewall.
    3. any port number over 10000 is generally good as theres a good chance no one is using it. dont use "6060"!
     

Share This Page