Torrent Woes

Discussion in 'macOS' started by paul.b.davis, Nov 12, 2007.

  1. paul.b.davis macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #1
    So I can no longer download anything with Transmission, and just to be sue the problem was not the app, I begrudgingly downloaded Azures and checked it, but to no avail.

    I am running 10.5 on a MBP and I have had Transmission work for me before on this exact setup, WHAT HAS GONE WRONG?????

    Thanks
     
  2. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #2
    here is a screenshot of what I think one of the problems may be (I don't know a lot about torrents)
     

    Attached Files:

  3. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #3
    I've heard of a number of problems with 10.5 and torrents. You might need to wait for an update from the software provider of choice.
     
  4. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #4
    i just tried tomato torrent too, and I am having the same problem

    that makes 3 apps with the exact same problem (which is that it always says downloading from 0 of 0 peers), which makes me think the problem is on my end
     
  5. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #5
    Did you check to make sure that your Sharing preferences are set correctly in Leopard? You might need to re-open ports that are closed by default when you install.
     
  6. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #6
    well i could try that, but I am not really sure what you mean... I looked in my sharing preferences pane and saw nothing about "opening ports"
     
  7. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #7
    When you installed with Tiger (as you said it was working 'before' I'm assuming you used to use Tiger) you must have opened ports in the Firewall in OS X to allow incoming/outgoing traffic that would normally be blocked. If you never did this in Leopard, you'll need to.
     
  8. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #8
    I'm sorry for being dumb... but how would I do this (I never remember doing it in Tiger, everything just worked)
     
  9. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #9
    I don't have Leopard, so I can't do a step-by-step for you, sorry. I know the menus have changed some with 10.5, so you'll have to wait for someone else with Leopard to come by and help more specifically.

    In Tiger you go to System Preferences->Sharing, then click the Firewall tab. From there you select "New" and make a new name, along with the ports you want to open. Save that, then check the box next to in in the Firewall tab.

    I'm not sure how it goes in Leopard, but it's probably similar.
     
  10. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #10
    well I found the firewall setting on the security panel in Leopard, this is what it looked like.

    any advice from any leopard folks? and thank you gauchogolfer for all your help already
     

    Attached Files:

  11. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #11
    install the latest 0.93 transmission update. open transmission and it should ask you if you want to allow incoming connections to transmission. click allow. it should set up the firewall automatically.
    if that doesnt work goto system prefs -> security -> firewall -> click set access for specific services and applications -> add transmission and set allow incoming connections. then check the port in transmission prefs. if its not open you then need to forward the port in your router. im assuming you already know this.

    EDIT i see you beat me to it and youve already figured out how to get to the firewall prefs :)
     
  12. DENZIE macrumors member

    DENZIE

    Joined:
    Apr 19, 2007
    #12
    hey mate, leopard's firewall comes default as 'off'. In other words it will allow all incoming connections. If you want to check, in system preference click security, then choose the firewall tab. Make sure it's set to 'allow all incoming connections' just incase.

    My question is, are you connected to a router/modem to access the internet? either with airport or ethernet? If so what you might need to do is go into the setup for the router (usually you type in an address into safari or firefox, type in a password if necessary and it'll bring up your router/modem, eg, 192.168.0..... the address would be with the manual of ur router/modem).

    From there you will need to look for either a tab called 'port fowarding' or 'firewall' or 'filter' or something like that. Then you need to 'allow' access through the port number, in your case '9090'.

    Once you think that you've set it up to be open, restart transmission.

    If this is the solution it is possible the modem/router could have been reset or something... i have always used transmission and when i first upgraded to leopard i think it was having a number of issues. I've since done a clean install of leopard and transmission 0.92 onwards (and indeed all my apps) is working great. hope i helped
     
  13. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #13
    thanks, i guess I will have to find the stuff for my router (it's my roommates) and figure some of that out
     
  14. DENZIE macrumors member

    DENZIE

    Joined:
    Apr 19, 2007
    #14
    perhaps before u do all of that, try getting transmission 0.93 (which came out today) and seeing if that fixes it. Perhaps its just a random bug..

    and unrelated to the port thing, if ur getting a torrent off demonoid, it won't connect cos demonoid has been shut down. at least for now
     
  15. paul.b.davis thread starter macrumors 6502

    paul.b.davis

    Joined:
    Oct 24, 2007
    Location:
    Over the hills and far away...
    #15
    i just got .93 and it did not work

    so I erased everything Transmission related and did it again, still no dice

    but, now that you mention it, I believe that my torrents in progress were hosted by demoniod (I got them from mininova), so that could be it
     
  16. synth3tik macrumors 68040

    synth3tik

    Joined:
    Oct 11, 2006
    Location:
    Minneapolis, MN
    #16
    I have ran both Xtorrent and Azureus with out any issues. I am running 10.5
     
  17. Reach macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Norway
    #17
    I think Leopard did something to mess up my Transmission too.. Worked before, gives a green light on bein gable to map port, but the port itself is stealth no matter what I do on the router, and the software firewall is off..
     

    Attached Files:

  18. H4L macrumors member

    H4L

    Joined:
    Oct 25, 2007
    Location:
    NZ

Share This Page