Toshiba external hard drive doesn't work on my rMBP

Discussion in 'MacBook Pro' started by hj123456, Jul 11, 2014.

  1. hj123456 macrumors newbie

    Joined:
    Jun 25, 2014
    #1
    I just purchased a late 13'' rMBP and I can't get the Toshiba external drive to work on it. I've checked the External disks option on Finder's preferences tab, but it's not being recognized... I've plugged it in & out several times, tried both USB ports, but it STILL doesn't show up on Disk Utility :( The blue light on the drive does come on however.

    It connects to a Windows laptop with no problem, and I even tried changing the format of it to FAT32. Googling didn't help much... saw that a lot of people were having a problem getting their HD to recognize after some OS updates, but couldn't find a solution.

    :( :( anyone know how to fix this??
     
  2. berker macrumors newbie

    Joined:
    May 10, 2014
    #2
    Which Toshiba HDD do you have?

    I am using Toshiba Canvio Slim and has no problem for over 6 months. Yet, I am using only Mac OS X Journaled format.

    Can you also try MAC OS X HFS+format, just to see if it will work?
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    If it's not showing up in Disk Utility then it's not a filesystem issue.

    Is there a separate connection for a power supply? I'm not sure about the newer MBPs but my old 2006 wouldn't see drives unless they were powered (this doesn't seem to be as much of a problem on my 2011, but I don't know about on the "retina" machines).
     
  4. hj123456 thread starter macrumors newbie

    Joined:
    Jun 25, 2014
    #4

    Toshiba Canvio 1.0 TB USB 3.0 Portable Hard Drive - HDTC610XK3B1

    This is the one I have. I want to format it to HFS but I don't know how to do that on a Windows laptop. The only options within the properties were NTFS and FAT32. That's why I was gonna connect it to my rMBP and format it from Disk Utility (that's what most websites I found stated), but my macbook doesn't even recognize it so I can't format to HFS.
     
  5. berker macrumors newbie

    Joined:
    May 10, 2014
    #5
    Hmmm, that seems weird! My guess is either your OS X has some failure or a flaw that resulted this "recognition" problem or the controller on the HDD has a problem all of a sudden. Yet, if you have a friend or a nearby Apple Store, try on a different macbook, just to confirm it is not caused by your OS X system.
     
  6. hj123456 thread starter macrumors newbie

    Joined:
    Jun 25, 2014
    #6

    Can you explain more on that please? I don't know what you mean by a separate connection for a power supply

    ----------



    Yeah I guess I'll have to try going to the Apple Store if Internet doesn't solve my problem! I really hope it's not a problem within my macbook though, I literally just purchased this few hours ago haha...
     

Share This Page