Toshiba External HD Extremely Slow speed [1mb/s]

Discussion in 'Mac Accessories' started by lawrenzo, Apr 17, 2014.

  1. lawrenzo macrumors newbie

    Joined:
    Feb 25, 2014
    #1
    Hello guys, I am not sure if I am writing in the right forum, but here is my problem and hope you guys can help.

    I have a toshiba canvio 1tb USB3 that is plugged into my retina mbp.

    The system tells me that it is recognizing the HD as USB3 and the speed is Up to 5 Gb/sec.

    I ran the BM Speed Test and the write/read speed stays at 1mb/s.

    In other posts I found that the problem might be the format, but mine is not FAT yet Mac OS Journaled.

    So what can be the problem ? how can I go fix it ? The disk utility app says that the disk is working fine too.

    I transfered 210 gb of video and it took precisely 1 day and 18 hours.

    Please help ! Thank you !
     
  2. wlossw macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #2
    Try another cable. Make sure you're plugged directly into the MacBooks USB port.
     
  3. Che Castro macrumors 603

    Joined:
    May 21, 2009
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    It sounds like a defective controller in that hard drive. Possibly a sign of failing. Try plugging it into another computer, and also verify that there are no speed issues with other devices on your rMBP.
     
  5. lawrenzo thread starter macrumors newbie

    Joined:
    Feb 25, 2014
    #5
    A usb2 drive that i have It's working fine ( 38mps) and the toshiba was doing the same thing on another computer. I'll probably back it up and throw it into the trash :(
     
  6. lawrenzo thread starter macrumors newbie

    Joined:
    Feb 25, 2014
  7. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #7
    Is it still under warranty? If you can get a replacement, it'll save you a small amount of money (better spent) :)
     
  8. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #8
    I can think of a few things:

    1. The electronics in the case are bad but the drive is good.
    2. It's using drivers that aren't working right.
    3. Cables/connectors inside the housing are bad.
    4. If it uses firmware, it might need an upgrade
    5. Bad sectors

    My point being I don't know if I'd throw the drive out. You could try Scannerz to test it, but I'd try simpler stuff first, especially look into the drivers.

    A lot of people end up tossing perfectly good drives because the electronics in the case are screwed up, and that happens more often than many may think.
     
  9. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #9
    Agree - pull the HD if possible.
     
  10. lawrenzo thread starter macrumors newbie

    Joined:
    Feb 25, 2014
    #10
    thank you so much man ! I already tried to re download drivers but it's actually a plug and play :(

    going out the window seems to be the only solution ! hate toshiba now ! :D
     
  11. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #11
    May be not enough power. Try to connect it via a powered USB 3.0 hub.
     
  12. lawrenzo thread starter macrumors newbie

    Joined:
    Feb 25, 2014
    #12
    So I used Scannerz and it detected no problem whatsoever. Does this mean I should throw the HDD away?
     
  13. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #13
    Compatibility problems with external drives and Macs are showing up all over the place. It doesn't mean the drive is bad. If you ran Scannerz on it and it passed it, it's working. But Scannerz is diagnostics software, not performance testing software. What it's telling you is there are no bad sectors, weak sectors, or any other problems with the drive, and there are no cable or system problems. This basically just leaves software.

    So why throw it away? You could return it or sell it.

    What makes you so certain the speed testing software is working properly?

    This may sound kind of dumb, buy you could take a large file (big, like gigabtyes) and copy it from one drive to another for a reference and measure the time it takes. Then to the same thing with the Toshiba. One will be faster than the other, but they shouldn't be that much faster unless you're comparing SSDs to HDs. In other words if a copy takes 1 min on one drive and 1 min 10 seconds on the other, it's normal and you're seeing normal variation. If you're getting a transfer to one drive of say 1 min, and then the Toshiba is taking 10 min. then yeah...there's a problem.

    ..but 50 bucks says it's in the drive configuration.
     
  14. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #14
    You might find the following link useful, even though it looks like it's about Windows:

    http://forums.toshiba.com/t5/Drivers-and-Utilities/Canvio-3-0-Plus-1Tb-Slow/td-p/304248

    It sounds like one possibility might be too little power. There are a fair number of posts on the web about those running on the slow side. Some are suggesting getting it to run off a higher power port, but I'm not sure it works. It might just be the nature of the drive.

    Google:

    toshiba canvio hard drive slow

    and see what crops up.

    You could always just use it as a backup of some sort or return it if not too late.
     
  15. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #15
    That may still be an oddity with the case. I was perusing OWC last night and noticed they were selling a bunch of Canvio cases for a few bucks each. This kind of tells me Toshiba is dumping the product or at least changing it to higher speed.

    The good part would be that, unless there was something special about the drive in it, if it's put in a new case, like a very basic USB case, it may perk up.

    No point in throwing away a working drive.
     
  16. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #16
    Does the Toshiba drive have a connection port for an external power supply?

    If so, try providing external power.

    If it didn't come with a power block, you can check the net, and probably pick one up for $5 or so.

    If NOTHING you do seems to get the drive to work faster, my "last ditch" advice would be to open the enclosure the drive is in, take the drive itself OUT of the enclosure, and try it in another enclosure, or in a USB3/SATA docking station.
     
  17. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #17
    It just occurred to me that you might want to check the configuration data for that drive and see if for some reason it's defaulting to USB 1.X instead of USB 2.X or greater. It's worth a look and that would explain the low data rate.
     
  18. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #18

Share This Page