Toshiba Hard Drive Mounting Issue

Discussion in 'macOS' started by jCrabb13, Dec 23, 2011.

  1. jCrabb13 macrumors newbie

    Joined:
    Apr 8, 2010
    #1
    I am often asked to do family chores related to the various devices everyone owns. This one has me in a bit of a pickle.

    I am dealing with a G5 Aluminum iMac, 27", mid 2011. This is a new device as the previous one was still having issues with the display and was recently replaced by AppleCare.

    The family member purchased a Toshiba Canvio Basics 3.0, knowing the compatibility said a reformat would be necessary (this is where I was called). It was not recognized by the iMac at all. Toshiba was of no help; they directed me to a guide on (of all places) macrumors on how to format it.

    I ended up connecting it to a dell laptop *shudders* to convert it to FAT32 so it would at least be recognized. Still nothing. Perplexed, I tested it on a G4 in the house as well as a '09 MBP (mine). Both read the device fine. while on the MBP I formatted it to Journaled, came back to the iMac and still nothing. none of the 4 USB ports worked for this particular HD. They have another Toshiba HD that reads fine every time in any USB port. switched cables, still nothing.

    Finally plugged it into the keyboard USB port on a whim, it connected and I started the transfer of information that we are trying to accomplish. Still curious why it's not working in any other ports on the back of the computer.

    Anyone have any ideas of other steps I could complete before calling AppleCare back tomorrow? T2 here I come :)

    tl;dr?

    G5 iMac mid 2011, 27"
    -10.7.2; software update shows nothing

    doesn't recognize Toshiba Canvio Basics 3.0 (status light doesn't even stay on)
    -Now formatted in Journaled, doesn't recognize
    -tested different USB cord; no change
    -tested different Toshiba HD; works

    Tried on '09 MBP and G4 iMac
    -both recognized in FAT32 and then in Journaled

    **somehow recognized on G5 when plugged into keyboard USB port**

    What's wrong with my USB ports? :/


    thanks for any advice guys!
     
  2. Heston macrumors regular

    Joined:
    Feb 13, 2007
    #2
    Hey man. Same problem, same hard drive. Apparently this is an issue that has only really surfaced within the past month with this hard drive. I've looked at other forums too. The drive works on my older Macbook Pro model but doesn't work with the newer Macbook Pro. It has to do with power consumption of the drive. Apparently it gets enough power from my laptop but not my girlfriends. I think I know a fix for it, albeit kinda unnecessary since it's a portable hard drive.

    If you have a USB hub, plug that into the laptop and then plug the drive into it. This will most likely work - this is all conjecture, but since USB hubs can be plugged in with external power sources, I'm guessing this will get the drive to work those computers that aren't pushing out enough amperage. I'm guessing that's exactly what's happing with the keyboard that you plugged it into. Somehow the USB port on that keyboard gives enough amps to get the drive going.

    Is this a problem with running USB 3.0 peripherals on USB 2.0 ports, or is it this ONE drive that's giving us trouble? That's rhetorical. Who knows....
     
  3. Heston macrumors regular

    Joined:
    Feb 13, 2007
    #3
    I bought a USB y cable:

    http://www.amazon.com/Apricorn-Power-Adapter-Cable-AUSB-Y/dp/B000JIOHDE

    When you plug the hard drive into the computers that it doesn't recognize, system profile will pick it up and says it's drawing 500mA of the 500mA available. My guess is that my laptop is somehow able to provide more. Hopefully this cable will solve this problem. I'll let you know if it works.
     
  4. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #4

Share This Page