Total mac noob with a G4 tower needing possible reinstall OS X :(

Discussion in 'Mac Basics and Help' started by sybercat, Mar 26, 2009.

  1. sybercat macrumors newbie

    Joined:
    Mar 26, 2009
    #1
    Hi guys and thanks for looking. I only know about PCs so this is driving me up the wall.

    Cant tell you much about it other than its a mac g4 with IBM deskstar 30 gb HD.. [ making scratch scratch scratch - click - scratch --- sounds.. hope thats normal for now] matching usb keyboard & mouse.. all 4 ram slots full.. I have the OSX box / manual.. OSX and OS 9 discs.


    Im trying to reinstall the OS X.. if I dont start up with the cd I get the flashing question mark thing.. havnt left it for hours or anything to see if it moves on from that.. presuming it wont.

    Ok so I let it start normally [no C holding] with the CD.. I get to the install screen and proceed and it says it cant find OS 9.1 but I can upgrade after OSX gos on.. I continue but when it gets to choose the destination disc the hard drive isnt in it.. it only shows the grayed out CDROM... currently behind me Ive left it for 15 minutes so far..... no drive appears..

    If I go into disc utility it picks up the disc, when I click verify it says in red 'invalid B-tree node' ..and somewhere else I forgot I read 'serious errors'.... also tried the same things via the OS9 disc. I go round in circles the repair dont work. I came across an 'initialise disc' question somewhere and said yes [chose extended, and standard in different attempts] and they fail straight away... tried erasing the disc from the top bar menu it seemed to be doing it but I dont know if it even has. It gives me the impression I need a better disc repair program?



    Or do I need a new hard disk or something? I have one but its not Mac.. does it matter? I wired it up instead of the other but it wont even find it in disk utility so I took it out.

    All your help would be appreciated.. it isnt my computer Im sorting it out for a friend.


    [late edit ] just adding that it was working fine before with what it has and the software there..
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Step one is to put in a new hard drive. If yours hasn't failed yet, it will do so soon. Any hard drive will work, so long as it is a 3.5" ATA drive.

    Based on the 30 GB hard drive, it's probably a Digital Audio or Gigabit Ethernet machine. (Updated Mac models are often informally named based on new or unique features or design elements.) That gives the computer either a 450 or 466 MHz processor and 128 MB memory standard. I'm suspecting that the machine has never been upgraded, so you would need to add more memory if you want to use it with a recent version of OS X. With the slower processor you're limited to Mac OS X 10.4 Tiger, the previous release, but it should run just fine with a 512 MB memory upgrade.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    Get new IDE drive. Drive up to 120gb will work fine without needing drivers.

    Drives above 120gb requires intech high capacity drivers, and proper partitioning.

    As with any IDE drive replacement, you want to see where your driver jumper setting is and set new drive jumpers to it.

    As to the install, looks like they are mostly upgrade disks? OSX don't typically need os9 to install though. You might want to list out the disk names (don't need to list disk 1 disk 2, just list each set).
     
  4. sybercat thread starter macrumors newbie

    Joined:
    Mar 26, 2009
    #4
    Thanks sorry I should add that it was working fine before with what it has and the software there.. apparently. My mate used to do some Adobe photoshopping with it.. he cant remember what went wrong it just failed one day. And no doubt it needs updating yes as he has no net.. but I can plug it into my net I guess.. via ethernet.

    So you say add ram but all 4 slots are full there should be enough there? must be at least 512- 1gb. Im not too familiar with ram sticks and knowing by eye.. 2 are higher than the others tho.. so not the same.

    And when I do put in the new hard drive, a Barracuda.. 40 gb.. [probably needing wiping] the mac install screen doesn't pick it up.. OR the disc utility area.. it just hangs for ages looking until I switch it off.

    So is there a bios screen in Mac like in windows where I can set the drive or something?


    The discs I have are

    1.mac os x version 10.0
    2.mac os 9 featuring sherlock.. SWW version 9.1
    3.developer tools disc

    Just those discs .. are there any missing? it seems to match the contents list..

    All in a big box with user manual priced £98.95 ....... Aqua desktop..


    [edit] powermac 3,3 4.2.8f1 [retrieved by control - z user abort]

    Oh and yes I think its gigabit, I noticed the airport ready part in there somewhere.......

    By the way if anybody needs a photo of anything feel free to ask I will sort it out.
     

Share This Page