Touch 4g randomly stops charging and ....

Discussion in 'iPod touch' started by st.will, Apr 1, 2011.

  1. st.will macrumors newbie

    Joined:
    Apr 1, 2011
    #1
    I've just recently bought an iPod touch 4g 64MB. When it sits in my docking station the charge icon flashes between charging and fully charged followed by the ' Charging not supported ' message. If I remove the ipod and re-dock its fine initially and then 5 minutes or an hour later it does it again. I've checked for debris in the docks connector, but all appears fine.

    The dock is a 'Made for ipod dock' that's been used for my old Touch 3g for over a year with no issues.

    I've tried a restore with no sucess.


    Any clues ?
     
  2. donlab macrumors 6502

    donlab

    Joined:
    Jun 3, 2004
    Location:
    USA
    #2
    Your new ipod isn't made for the old dock. Try connecting with just a cable to a computer and see if it charges.
     
  3. st.will thread starter macrumors newbie

    Joined:
    Apr 1, 2011
    #3
    This is the new type dock that charges via USB and not firewire . It charges the touch G3 and the latest nano fine, both of which fail to charge on the old docks like the sharp DK.

    It charges mine most of the time, its the random way it decides to stop charging that appears bizarre.

    Apple said the Touch G4 is no different to the touch G3 for charging :confused:
     
  4. Panther71 macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Cham-Bana, IL
    #4
    You will probably need to purchase the Scosche passPORT USB Charging Adaptor. This is what I had to purchase for my iPod dock that had previously worked with my 5.5 Gen iPod
    Classic. Using this, the 4th Gen iPod Touch will recharge without any issues.
     
  5. st.will thread starter macrumors newbie

    Joined:
    Apr 1, 2011
    #5
    Why ?

    My ipod dock charges the nano and touch 3g fine, it also charges my touch 4g 60% of the time.

    I've since found out that many people who went from IOS3 to IOS4 also have charging problems similar to mine.

    My dock is the new Made for Ipod USB charger that is designed to charge the ipod 4g, except Apple appear to have stuffed something up in IOS4.
     

Share This Page