Touch Bar - disappearing buttons

Discussion in 'MacBook Pro' started by ctyrider, Jan 3, 2017.

  1. ctyrider macrumors 6502a

    ctyrider

    Joined:
    Jul 15, 2012
    #1
    I have seen a few others report this issue in various places, but wanted to start a new thread, as this has been bugging the heck out of me.

    So, basically, my Touch Bar either loses multiple buttons or goes completely blank, while the keyboard is active. Usually, this happens immediately after Touch Bar wakes up from "sleep". The way to "recover" the buttons is to touch on a blank area, where the missing botton then re-appears.. or hitting Fn key restores the whole bar, at least temporarily until it happens again.

    This seems to have gotten worse since 10.12.2 update, but maybe I am just noticing it more now.

    How many more people are having this issue? Have any of you contacted Apple, and what have they suggested?

    [​IMG]
     
  2. thesaint024 macrumors 65816

    thesaint024

    Joined:
    Nov 14, 2016
    Location:
    suspension waiting room
    #2
    I have noticed similar behavior, but honestly, I chalked it up to not knowing how the touchbar is supposed to behave. It sounds like it is buggy. Still getting used to it, since I only use my MBP undocked maybe 25% of the time.
     
  3. philosopherdog macrumors 6502a

    philosopherdog

    Joined:
    Dec 29, 2008
    #3
    I had the slider stop working which a reboot fix. Report it as a bug.
     
  4. smfinlay macrumors member

    Joined:
    Mar 2, 2008
    Location:
    Central Florida
    #4
    Same issue here. I was about to start a new thread but found this one. It's seemed to get progressively worse recently. And like you, I mainly notice this behavior after the touchbar wakes from "sleep".

    Screenshot 2017-01-04 20.34.34.png
     
  5. junebug1 macrumors regular

    junebug1

    Joined:
    Jan 24, 2007
    Location:
    NE Ohio
    #5
    I've had it happen to me 2 different times when waking from sleep. Just a few random buttons are blank and then once you touch the missing area the button returns and functions as normal. Feel likes its a very small minor thing that will be addressed in an update soon.
     
  6. FrightWait macrumors newbie

    Joined:
    Nov 25, 2016
    #6
    I ave also just experienced this issue. My only concern is that given the touch bar is controlled by the T1 Chip which is separate to the CPU, could this be a hardware problem?
     
  7. leman macrumors G3

    Joined:
    Oct 14, 2008
    #7
    Yep, there are some bugs here and there. For example, my TouchBar consistently crashes in Messages when I want to use an emoji. Its probably an app-specific bug though.
     
  8. New_Mac_Smell macrumors 68000

    New_Mac_Smell

    Joined:
    Oct 17, 2016
    Location:
    Shanghai
    #8
    It's just software bugs. Don't worry about things so much, your computer isn't going to fall apart.
     
  9. Joe_ver macrumors newbie

    Joe_ver

    Joined:
    Jan 9, 2017
    #9
    Mine totaly died, no buttons, config option disappaered in system preference. Did several resets and clean install. But no touch bar at all. Bring it back to shop and now waiting .......
     
  10. nikhsub1 macrumors 68020

    nikhsub1

    Joined:
    Jun 19, 2007
    Location:
    mmmm... jessica.'s beer...
    #10
    I had similar weirdness with my bar, a reboot has fixed it so far...
     
  11. hadschii macrumors newbie

    Joined:
    Jan 7, 2017
    #11
    Anyone was able to narrow it down? maybe some software?
    The missing touch bar icons is happening quite often to me.
     
  12. natebookpro macrumors 6502a

    Joined:
    Sep 25, 2008
    Location:
    Maryland
    #12
    I saw another post somewhere that always seems to work for me. If I hit the Function key to bring up the function keys, when I release it the Touchbar is fixed.
     
  13. ctyrider thread starter macrumors 6502a

    ctyrider

    Joined:
    Jul 15, 2012
    #13
    Yes, that's a workaround I mentioned in my original post. It is not a "fix" by any means, as the issue re-occurs later.
     
  14. natebookpro macrumors 6502a

    Joined:
    Sep 25, 2008
    Location:
    Maryland
    #14
    Sorry about that, saw it somewhere a few weeks ago and just wanted to help out. I understand it's only a workaround for the time being, but it does fix the issue a lot quicker than the resetting and other things I was seeing in the thread. Didn't mean to offend anyone or try to steal credit.
     
  15. Gonza211 macrumors newbie

    Joined:
    Jul 26, 2012
    #15
    I have called Apple regards this and Im working directly with an AppleCare Engineer to fix this in the next software release. I have identified that this happens whenever you connect the Macbook to an external monitor. Then let it sleep, and disconnect it to use it without the monitor. The Touch Bar will glitch that way. only way to fix is reboot or hit the Function key. Will bookmark post and keep you updated.
     
  16. mingmingming macrumors member

    Joined:
    Nov 14, 2016
    #16
    I have the same issue and filmed a video. I have found this issue before I update 10.12.2. I have brought my laptop to the Genius Bar and the technician diagnosed and report indicates no hardware issue with my 13" new MBP.
     
  17. Turpentine222 macrumors newbie

    Joined:
    Dec 29, 2016
    #17
    This happens to me VERY often. Including the TouchID button taking 4-6 seconds to appear after the laptop wakes up from sleep.

    I'm an optimistic person who figures this is most likely a software issue and will get fixed, hopefully sooner than later.
     
  18. ab8 macrumors newbie

    Joined:
    Feb 5, 2017
    #18
    This happens all the time - across two units now. The keyboard on the first unit also began to fail.
     
  19. Turpentine222 macrumors newbie

    Joined:
    Dec 29, 2016
    #19
    It looks like the latest beta of Sierra has solved the disappearing buttons issue on my side. Haven't that problem in about a week.
     
  20. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #20
    I just found this thread while searching around for others having the same issue with buttons disappearing. It's very obnoxious. I figured it was a software issue that would be easily fixed. Glad to hear that seems to be the case.
     
  21. ab8 macrumors newbie

    Joined:
    Feb 5, 2017
    #21
    Fingers crossed!
     
  22. trchicago, Feb 26, 2017
    Last edited: Feb 26, 2017

    trchicago macrumors newbie

    Joined:
    Jul 31, 2012
    #22
    So I had this issue. It seems that Apple associates on the phone and the Genius Bar have not really experienced this issue frequently. My MacBook went out for repairs twice. They replaced the top case the first time. Second time the logic board and the cable that goes to the control stripe. The third time they said there was no more parts to really replace. They did a fresh o/s install at the Genius Bar, did not fix. Finally after all that, they replaced my unit. Just received my new unit and it happened after 3 hours when waking from sleep. This must be a software bug. Whatever you do not try to send out for fixing, it will not help.
     

Share This Page