Touch ID not working

Discussion in 'MacBook Pro' started by mikeyiphone, Oct 6, 2017.

  1. mikeyiphone macrumors regular

    Joined:
    Jun 10, 2009
    #1
    When I try to sign on I use the touch ID and nothing happens. Its not even saying retry or anything of that nature. So I'm forced to use my password.

    I tried deleting the fingerprint and adding a new one, when i did that it, at first, it didn't read my fingerprint. So i deleted the null fingerprint and tried to create a new one and it read it.

    but then i close the lid an try to log back on and it won't read my fingerprint.

    Anyone else have this problem?
     
  2. Yeahyeahyeah123 macrumors member

    Joined:
    Jul 30, 2017
    #2
    Try cleaning the sensor with a microfiber cloth and wash your hands to get rid of excess oils.
     
  3. mikeyiphone thread starter macrumors regular

    Joined:
    Jun 10, 2009
    #3
    I don't think thats the issue. My iPhone is working fine and never gives me any issues.
    It seems to work when it wants to.
     
  4. Yeahyeahyeah123 macrumors member

    Joined:
    Jul 30, 2017
    #4
    I just know my sensor acts up sometimes and when I do those two things, it tends to fix the problem. Also, the way I am seated/finger is positioned can affect it too.
     
  5. andy9l macrumors 68000

    Joined:
    Aug 31, 2009
    Location:
    England, UK
    #6
    So you’re saying it appears it’s not even trying to read your finger?

    Assuming you’ve tried the usual reboot/SMC reset/PRAM reset, I would probably suggest an OS reinstall at this stage.
     
  6. New_Mac_Smell macrumors 68000

    New_Mac_Smell

    Joined:
    Oct 17, 2016
    Location:
    Shanghai
    #7
    Your iPhone will be constantly going into/out of your pocket and getting a little clean. The MBP doesn't have this luxury, so you do actually need to physically clean it every once in a while if you haven't done so. The oils can build up and effect the optical properties of the sensor, distorting the registered print a little which will cause false readings (This is a security thing, it needs to be 100% not near enough).

    Just try cleaning it and report back, otherwise you'll go down a rabbit hole of random solutions when it could just take 3 seconds to sort out.
     
  7. creativesmith macrumors newbie

    Joined:
    Sep 28, 2011
    #8
    Yes, am experiencing precisely the same issue. Have deleted and added fingerprints, reset SMC and NVRAM, etc. Problem persists. (And have cleaned the sensor… and washed my hands.)
     

Share This Page

7 October 6, 2017