Touch screen intermittently unresponsive (Iphone 4s)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JayKay321, Nov 9, 2011.

  1. JayKay321 macrumors member

    Joined:
    Nov 7, 2008
    #1
    Anyone experiencing the touch screen sometimes not responding?

    I'd say this happens to be 1 out of every 15-20 clicks...by 'click' I mean any instance of touching the screen whether this means typing out a text/email or opening applications.

    In the case of apps, I know the iphone is recognizing my touch because the icon turns grey (like it normally does right before it opens). However, in my case it turns grey then does nothing.

    --Jay
     
  2. warxy macrumors newbie

    warxy

    Joined:
    Sep 11, 2011
    Location:
    Perth
    #2
    Nope. Try clearing the apps in the task switch thing.
     
  3. JayKay321 thread starter macrumors member

    Joined:
    Nov 7, 2008
    #3
    How would this help with the response?

    Also, I do often clear the apps in the task bar just to save battery and the problem still exists (esp with google maps)
     
  4. NZPacifikRoze macrumors newbie

    Joined:
    Oct 27, 2008
    #4
    My touchscreen is similarly unresponsive, well mainly the top half. could you do me a favour to confirm if there really is a bug? Open up Safari on your iPhone 4S, tap on "google/yahoo" search up on top right hand corner, then see if you can click on "cancel"... I can't, it just wouldn't work.

    ----------

    Also are you able to draw down the notification centre? Mine just wouldn't work, not sure if it's a bug!

    Thank you
     
  5. monkeymajik macrumors newbie

    monkeymajik

    Joined:
    Jul 19, 2010
    #5
    My iphone 4 LCD bottom left is also not function normal.

    Already change the LCD+digitizer twice.
     
  6. iwannaknow macrumors newbie

    Joined:
    Feb 26, 2011
    #6
    My iPhone 4S has always been slow to respond and it is becoming worse. Often it take several touches from different angles before the screen responds to my touches at all or it will keep putting the cursor in the wrong place if I am trying to highlight text or put the cursor in a specific place within text. It's driving me nuts.
     

Share This Page