Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPod touch touchFree: GUI Jailbreak with automatic SummerBoard installation

planetbeing

macrumors member
Original poster
Oct 11, 2007
87
0
THIS IS DEPRECATED, VISIT THE OFFICIAL WEBSITE FOR NEWER JAILBREAKS: http://www.slovix.com/touchfree/

Here are my recommended methods:

Easiest: https://forums.macrumors.com/threads/377126/

Requires Java (but older and more tested): http://www.slovix.com/touchfree/alpha2.zip

If those don't work, I would advise the older alpha (it's now been well-tested, but it does lack auto-install of SSH): http://www.slovix.com/touchfree/touchfree-alpha.exe

RESTORE INSTRUCTIONS
------------------------

It is impossible to brick, or render permanently inoperable, your iPod touch. These instructions will work. Repeat them if they do not work the first time (since some of the manuevers do require good timing).

My previous restore instructions did not work so well as I found out when I first tried to test them (they were copied off of another website). I apologize for that, but here are the ones that do work for me every time:

1. If the iPod is on, turn it off. If it is not responding to commands, hold down the Home and Stand-by buttons until it turns off (will be less than 30 seconds).
2. After it has turned off, turn it back on with a special key combination. First push the Stand-by button, then push the Home button while still holding the Stand-by button. You must already be holding the Home button by the time the Apple logo displays.
3. Within moments, the Apple logo will display. At this point, release the Stand-by button but do not release the home button.
4. Hold the Home button until the logo asking you to plug the iPod into iTunes displays. You are now in Restore Mode.

Essentially the last three steps are this:
1. Push down the Stand-by button.
2. Push down the Home button.
[Apple logo displays]
3. Release the Stand-by button.
[Connect to iTunes displays]
4. Release the Home button.

If iTunes still errors during Restore, a reboot of your COMPUTER will often fix the issue. If not, just take it to a friend's computer or reinstall iTunes. Trust me, your iPod is not bricked. If you think it's bricked, I'd be glad to take it off your hands for $10. ;)

Older stuff:

Old command line version (revision 5): http://zoo.cs.yale.edu/~yw226/ipod/touchfree5.zip

Source (for revision 5): http://zoo.cs.yale.edu/~yw226/ipod/source.cs

Old readme:

NOTES ON SSH/SFTP
-----------------

- Username to SSH is root, password is alpine
- Recommended SSH client is PuTTY
- Recommended SFTP client is WinSCP
- If you're getting "connection timed out" errors, continually browse with Safari on the iPod
while trying to connect to keep wi-fi active.


NOTES ON iPhuc
--------------

- iPhuc will not show / after this procedure, but you can get root by typing the following command into iPhuc:

setafc com.apple.afc2


NOTES ON RESTORING
------------------

You can restore at any time during or after the jailbreak process. Your iPod will be in a fresh, un-jailbroken
state.

If you're having trouble restoring your iPod, first put it into recovery mode.

If you're still having trouble, a reboot of your computer is often helpful.

I end the iTunesHelper.exe process, which is responsible for launching iTunes whenever an iPod is connected. So if you connect your iPod and iTunes doesn't appear and sync as always, just open iTunes yourself and tell it to sync. It should work fine. A reboot of your computer will restore the iTunesHelper.exe process.
 

Spoolin

macrumors newbie
Oct 10, 2007
13
0
Sydney, Australia.
Sounds great!

One quick question. I sync my iPod from my Mac, but I also have a PC.

Could I Jailbreak my iPod from my PC and then still sync with my Mac?

Thanks. :)
 
Comment

planetbeing

macrumors member
Original poster
Oct 11, 2007
87
0
By close iTunes do you mean just close or end all the processes?

touchFree will try to end all the processes, but sometimes iTunes refuses to close and touchFree appears to just hang. So it's probably safest to end all the processes associated with iTunes yourself.
 
Comment

cracker

macrumors newbie
Oct 11, 2007
20
0
Can anyone help me out? While running touchfree.exe, it gets to reading ipod flash image then to patching ipod flash image. but then after that i receive an error message from windows and it closes the process. any pointers?
 
Comment

mufasa

macrumors member
Sep 14, 2007
69
0
plz help, I jailbreaked the iPod but got no idea how to put apps on it. I downloaded the iPhone apps and all but got no idea how to put the apps on it. I read some guides on this and it says I need sprt for it. how do I open this sprt program, I used your guide to jailbreak my iPod and got no clue how go open this sprt thing so I can access the /Applications/ folder. plz tell me if its in the zip folder for touchfree3 and if so what name. Also I need to use SSH in the end to do this command thing, where is that located
 
Comment

jay81

macrumors member
Sep 19, 2007
60
0
Are these steps it or is there more? How long does this take. Is there a different process for installing the actual apps once its jailbroken?

thanks
 
Comment

beg_ne

macrumors 6502
Jul 3, 2003
452
0
Is anyone else still having major problems getting iNdependence installed? I've got iphuc working and everything is reuploaded to the ipod and working great, i've restarted the ipod using the slider method like it says everywhere. iNdependence says everything is good but it says failed each time...

Anyway if someone has a solution that would be great.

HOWEVER you don't HAVE to get it installed to atleast try a few things (I mostly wanted to get the missing iPhone apps on it). I found out a way to get around having to use SSH mostly by using the easier method found here to get springboard patched and installer.app installed.

http://www.touchdev.net/wiki/Talk:Jailbreak_Guide#Install_Installer.app_-_An_Easier_Way

I followed those instructions, as well as downloaded the iPhone 1.1.1 apps and put those in the Applications directory on the mounted disk image.

This is great, but the perms are wrong and the apps will just crash....

in order to fix that open terminal and do this:
chmod -R a+x /Volumes/Snowbird3A110a.N45Bundle/Applications/*

I did this by typing the first part of the chmod command in and then dragging the Applications frolder from the mounted image, then adding * at the end.

After running that I was able to unmount the image and used putfile via iPhuc to put the .dmg to the iPod.

So far I can atleast play with my apps.

If anyone is in iNdependence hell like I was hopefully this will help you.
 
Comment

Spoolin

macrumors newbie
Oct 10, 2007
13
0
Sydney, Australia.
Can anyone help me out? While running touchfree.exe, it gets to reading ipod flash image then to patching ipod flash image. but then after that i receive an error message from windows and it closes the process. any pointers?

Yep, I get the same thing.

I have followed the instructions down to a T.

Running XP 2000
Moves iTunesmobiledevice.dll to same folder as touchfree.exe
Restored my iPod
Yes, I have .NET Framwork 2.0 installed
Yes, I visited http://jailbreak.toc2rta.com on my ipod and safari did crash.
Ran touchfree.exe and I got up to 'patching ipod flash image' and then got a error mesage and the program crashed

Any ideas how to get this fixed? :(

Chris.
 
Comment

mufasa

macrumors member
Sep 14, 2007
69
0
plz help, I jailbreaked the iPod but got no idea how to put apps on it. I downloaded the iPhone apps and all but got no idea how to put the apps on it. I read some guides on this and it says I need sprt for it. how do I open this sprt program, I used your guide to jailbreak my iPod and got no clue how go open this sprt thing so I can access the /Applications/ folder. plz tell me if its in the zip folder for touchfree3 and if so what name. Also I need to use SSH in the end to do this command thing, where is that located

plz guys I've been on forums for hours looking for a answer to this, help me plz.
 
Comment

beg_ne

macrumors 6502
Jul 3, 2003
452
0
Well sweet I finally got iNdependence to work. I was messing with the SpringBoard plist to get editing in mobilecal and had to reupload the system .dmg. After restarting this time and trying to reinstall iNdependence it finally worked!

Which enabled me to do the necessary changes to have iTunes sync!

Everything is working great now!
 
Comment

planetbeing

macrumors member
Original poster
Oct 11, 2007
87
0
Ran touchfree.exe and I got up to 'patching ipod flash image' and then got a error mesage and the program crashed

Any ideas how to get this fixed? :(

Chris.

How much time did it spend on reading the iPod flash image? Do you have a 300 MB file called rdisk0s1 in the same directory now?

One more question. Are you using firmware version 1.1.1 or the one that came with the iPod?
 
Comment

AkiNikoTanTan

macrumors member
Jun 26, 2007
85
0
how long does it normally take to "patching ipod flash image"??

its taking so long... i have .NET Framework 2.0 installed, by the way i actually got it jailbreaked but i was kinda confused which steps to go next, i think i got it screwed up and thats why i decided to run touch.exe again.

though i am using mac,i using parallels to run the jailbreaker for windoze :(


i cant restore it, using iTunes, how can i restore it to begin the hack again?
 
Comment

Dublo7

macrumors regular
Sep 30, 2007
157
0
Perth, Australia.
Being, do you know why this error occurs? It happens while patching the ipod, and it happens immediately.
 
Comment

verrater

macrumors newbie
Oct 12, 2007
16
0
Ok i get this no one can provide me with any help so far ?

Planetbeing what do you think?

Please help been trying to jailbreak for 3 days...
 

Attachments

  • fstabyou.JPG
    fstabyou.JPG
    40.7 KB · Views: 1,279
Comment

planetbeing

macrumors member
Original poster
Oct 11, 2007
87
0
I have version 7.2, which I assume is the latest.

http://zoo.cs.yale.edu/~yw226/ipod/QTMLClient.dll

Try putting that in the same directory as everything else. See if that's the same as the version you have, which should be at

C:\Program Files\QuickTime\QTSystem

This is probably the only program on Earth that works better on Vista than on any other version of Windows, btw.
 
Comment

planetbeing

macrumors member
Original poster
Oct 11, 2007
87
0
ya i know i have restored like 5 or 6 times it says its 1.1.1 (3a110a) so i dunno any thoughts as what to try ?

There should be a file called fstab now in the same directory as touchfree. Paste its contents here.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.