Track Pad Stuck on Right-Click/Drag

Discussion in 'MacBook Pro' started by EroticCelery, Oct 27, 2009.

  1. EroticCelery macrumors newbie

    Joined:
    Jul 31, 2008
    #1
    Hi,

    I did a search and didn't see anybody with the same problem. I have an Oct 2008 (unibody) MBP with 2.8 ghz core 2 duo, 4GB RAM, 320 GB 7200 RPM HDD.

    So I loaded a YouTube page, paused a video to let it load and suddenly when I tried to click "play" the track pad seemed to not be working. I then realized that it was highlighting all the text and I couldn't click out of it. Likewise, when I apple-q safari, it began selected icons in my desktop. I noticed I could still two-finger-tap to right click and open a context menu, but I can't select anything within that menu.

    I can't imagine the notebook suddenly became damaged. I know early macbook pros had a similar problem due to the battery swelling, but I opened the battery compartment and the battery feels very cool. I also read that resetting the SMC and repairing disk permissions might help, but that didn't do anything either.

    Anyone know of a fix?
     
  2. tacovertical macrumors newbie

    Joined:
    Aug 29, 2010
    #2
    Did you find a solution?

    I am having the same problem with my MacBook Pro, same specs. If you could point me in the right direction that would be awesome!

    Thx,

    taco
     
  3. jaredbehunin macrumors newbie

    Joined:
    Dec 2, 2010
    #3
    Same Problem Here, weird side effects

    I am having possibly the same problem. It came on all of the sudden. It appears that I am holding down the left click on the desk top, creating the drag window to select multiple files...

    Here is where it gets weird.

    I pluged in a usb optical mouse. If I DO NOT touch the track pad the usb mouse works. if I touch the track pad at all, the problem comes back... then the usb mouse stops working.

    WORK AROUND. while the usb mouse was good, I went into mouse pref and checked to ignore trackpad when other mouse is enabled. From there I was able to get my bluetooth mouse working, so I have a functioning system.

    I have tried clearing the PRAM. I tried the command line rm ~/library/preferences/.Global*. I have disabled and removed every bluetooth item in my system. I have rebooted in safe mode.... the problem persists. I know its not a hardware thing, because the clicker on the trackpad is not stuck (plus I always use the tap gesture, I never actually push in the clicker). It's not a blown out battery pushing up against the inside of the mac (aluminum).

    Thoughts??

    13 inch Macbook (Aluminum unibody) 2 GHz Intel Core 2 Duo, 2 GB 1067 MHz DDR3. OSX 10.6.5. 160 GB HDD.
    Currently using a Microsoft Bluetooth Mouse 5000 with mac Intellipoint drivers.

    Jared
     
  4. defy69 macrumors newbie

    Joined:
    Dec 1, 2010
    #4
    maybe dust? try taking out the battery and blowing on the back side of the track pad. mine has gotten stuck a few times but never in a right click drag situation.
     
  5. Terro macrumors newbie

    Joined:
    Jan 3, 2008
    #5
    Mousepad Auto Clicking

    The problem seems to lie in the poor placement of the battery pack, if your like me you either put the laptop down to hard or pushed it in over the years, and now it's too tightly packed under the mousepad and putting pressure on it.


    I can't figure out how to have the battery pack put in and locked without it pushing the mousepad, so for now all i know what you can do is unlock it, and tape it "lightly" so that it is no longer pushing against the mousepad so tightly, i would love to find a less simple way of fixing this.. This is kind of ridiculous. (I also noticed as soon as i unlocked the battery pack that the mousepad clicker sounded differently)
     
  6. BurningJah macrumors regular

    Joined:
    Apr 15, 2010
    Location:
    Belgium
    #6
    I have the same "problem" but I don't mind! when I notice it I just start clicking on the mousepad and it's goes away!
    you will learn to live with it!
     
  7. Terro macrumors newbie

    Joined:
    Jan 3, 2008
    #7
    BurningJah, mine was doing that at first, after a half year or so it will get to the point where it will no longer work correctly, i think it has to do with the lithium battery expanding
     

Share This Page