Trackball Issue

Discussion in 'Mac Basics and Help' started by macattac, Mar 22, 2006.

  1. macattac macrumors newbie

    Mar 20, 2006
    Hi, I'm a noob to the board and Macs.

    I recently purchased a Logitech Marble Mouse. When I first plugged it in it worked, then I installed the mouseware software and it stopped working (freezes). I called Logitech support and they didn't help me at all. I reboot my power mac G4 and if the mouse is plugged into the USB port the computer won't boot up. I have to unplug it for the computer to boot. I tried uninstalling the mouseware drivers and I still have the same issue. I'm running OS 9.2.2 and I'm using Protools. Any advice? Thanx.
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    If the computer won't boot and another trackball or mouse works in that same USB port, I'd return the thing. I have two Trackman Marble trackballs and they both work well. I'm not using it with Mac OS 9.x now but nothing on the USB ports should stop the machine from booting. If their support people can't determine that, they're confused.
  3. macattac thread starter macrumors newbie

    Mar 20, 2006
    Basically, I think they have the worst technical support I've ever dealt with.

Share This Page