Trackpad and keyboard unresponsive

Discussion in 'OS X El Capitan (10.11)' started by Skylitfly, Aug 17, 2015.

  1. Skylitfly macrumors 6502a

    Joined:
    May 3, 2014
    #1
    My trackpad and keyboard are unresponsive for about 5-10 seconds after I open the lid and my Mac wakes up from the sleep. I've only experienced this bug on the latest beta.

    Anyone else experiencing this? Do you have possible solutions or work arounds?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Could be a number of things causing this, or could just be a bug in the latest beta iteration. So if you'll bear with me we'll go through some diagnostics. A lot of these are unlikely to be causing the problem, though for the minimum time/effort it's worth checking anyway.

    1) Check HDD SMART data to see if the hard-drive's corrupted. You can do this by downloading SMART Utility here. Anything other than 'Passed' means you need to replace your hard-drive

    2) If that comes out clean, open Disk Utility and click 'Verify Disk'. Make sure you verify the OS partition (bottom of the two 'Macintosh HD' listed). If you have red writing, it needs to be repaired. Green writing or no writing means it's OK. Please quote this if it's red and you need assistance repairing.

    3) If Disk Utility comes out clean, try restarting with the option 'Reopen windows when logging back in' disabled.

    4) If that hasn't fixed the issue, try a permissions repair and restart.

    5) Reset PRAM/SMC.

    6) If you're still having the issue after this then I'd probably submit a bug report.

    Also, could you confirm the following:

    - Does the issue happen with USB mice/keyboards, or is it just the internal devices?
    - What model of MacBook do you have?

    Speak soon.
     
  3. Skylitfly thread starter macrumors 6502a

    Joined:
    May 3, 2014
    #3
    1) This came out passed.

    2) Disk Utility came out clean.

    3) Didn't work.

    4) Didn't work.

    5) Reseted both PRAM and SMC. No effect to my issue. But reseting PRAM caused another issue that I didn't have before.

    6) I already sent a bug report.

    Happens with any input method.
    I have MacBook Pro 15" Retina (Early 2013)
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hi there Skylitfly, thanks for taking the time to do that. From what you've said it's definitely an OS bug and I don't think there's anything you can do to fix it other than hoping it's patched in the next DP.
     
  5. patstar, Aug 17, 2015
    Last edited: Aug 17, 2015

    patstar macrumors newbie

    Joined:
    Aug 17, 2015
    #5
    Same Problem here. In Console, i find something about the AppleMultitouchdriver and the USBKeyboard driver.
    So i tried it with my Magic mouse an BT Keyboard -- Same Problem.

    I think something is wrong with die USB driver.


    Do you have installed 3rd Party USB drivers ? Like JetDrive Lite or something ?
     
  6. Skylitfly thread starter macrumors 6502a

    Joined:
    May 3, 2014
    #6
    No problem. Yeah, thats what I thought so. Let's hope that Apple addresses this on the next beta release.
     
  7. tcraymond macrumors newbie

    Joined:
    Aug 18, 2015
    #7
    I have had this problem since the first Beta. It has reduced in frequency since then. I have had two hangs since Beta 6. Out of curiosity, do any of you have VMWare Fusion installed?
     
  8. patstar macrumors newbie

    Joined:
    Aug 17, 2015
    #8
    I'm using Parallels Desktop.

    Is it fixed in the new Public Beta 5?
    Can anyone try?
     
  9. patstar macrumors newbie

    Joined:
    Aug 17, 2015
    #9

    EDIT: Fixed in Public Beta 5
     
  10. Skylitfly thread starter macrumors 6502a

    Joined:
    May 3, 2014
    #10
    Yeah, definitely fixed in PB5.
     

Share This Page