Trackpad and mouse erratic/overactive

Discussion in 'MacBook Air' started by apfel2k, Dec 3, 2014.

  1. apfel2k, Dec 3, 2014
    Last edited: Dec 3, 2014

    apfel2k macrumors newbie

    Joined:
    Dec 3, 2014
    #1
    Hey guys,

    Since yesterday I have a serious problem with my macbook air mid 2012, os x 10.10.1

    The trackpad is unresponsive, but overactive. It just clicks where it likes to and moves around thereby highlighting things and moving stuff around. Additionally, a cable external mouse is affected as well. The left click does not work, sometimes scrolling fails and so on.

    I worked through this list: https://discussions.apple.com/thread/6686987

    But nothing helped. Please, if anyone has an idea this would be so much appreciated! I am very frustrated and need the notebook for work.

    Cheers,
    Malte

    EDIT: I activated the option: ignore trackpad when mouse is connected in the accessibility preferences. The external mouse now works fine! Maybe this helps to tackle the problem.
     
  2. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    Location:
    Chile
    #2
    This happened to me in my MBP. The only thing that worked for me was. to repair permissions. I do not know why, but it worked in my case.
    Hope this helps.
     
  3. apfel2k thread starter macrumors newbie

    Joined:
    Dec 3, 2014
    #3
    Yes, I tried this twice, it did not help. Only thing that would pop into my head would be moisture, so maybe it works again in a couple of days..
     
  4. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    Location:
    Chile
    #4
    How did it go? Any luck?
     
  5. apfel2k thread starter macrumors newbie

    Joined:
    Dec 3, 2014
    #5
    Unfortunately no change so far. But I'll give it some more time before I rush to the genius bar I guess :)
     
  6. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    Location:
    Chile
    #6
    Sorry to hear that. Besides the possible hardware problems that may cause this (dirt, crumbs, battery swelling, etc.), I am sure that this may also be caused by a software problem.

    If you have a backup you can try to restore the system to a state prior to the malfunction?
     
  7. apfel2k thread starter macrumors newbie

    Joined:
    Dec 3, 2014
    #7
    If the problem does not solve itself by monday I will just re-install the system and see if it's gone. I'll keep you posted, thank you for your help!
     
  8. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    Location:
    Chile
    #8
    reset the trackpad?

    Did you have a look at this thread? http://forums.macrumors.com/showthread.php?t=268530

    Post #2 talks about resetting the trackpad, something I never tried.
    There is also to an old thread that probably relates to the same issue.
     
  9. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    Location:
    Chile
  10. apfel2k thread starter macrumors newbie

    Joined:
    Dec 3, 2014
    #10
    Nothing worked. I am still having the problem after erasing my harddrive and reinstalling mac os x. I used an external mouse for more than half a year now but I really need this trackpad to be working again :D. So what do you guys think? I believe the only option left is hardware. But I don't know if it's the trackpad itself or the mainboard or something else :/. As a student, I only have money to fix it myself :D
     
  11. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #11
    I think some people have had problems with the battery swelling and pushing on the trackpad. You might try opening the laptop and checking out the battery and seeing if there are any obvious problems?
     
  12. apfel2k thread starter macrumors newbie

    Joined:
    Dec 3, 2014
    #12
    Thanks I will try that tomorrow. Maybe if it's not the battery, I can find something else which could cause this
     
  13. sracer macrumors 604

    sracer

    Joined:
    Apr 9, 2010
    Location:
    in exile
    #13
    Do you have Microsoft Office 2011 for Mac installed? I just bought a 13" non-retina MBP for my wife 2 days ago. It came with Yosemite. We had great difficulty with pairing a bluetooth mouse with it. Turns out to be a fairly common issue with Yosemite.

    But shortly after installing Office 2011 we noticed erratic touchpad behavior... the pointer would move by itself and randomly register mouse clicks. I chalked it up to Yosemite weirdness and downgraded to Mavericks (which we prefer anyways)

    All was well. BT pairing was great. Touchpad worked fine. After installing MS Office 2011, the erratic touchpad behavior returned. At this point we considered the possibility of a hardware error. But before reinstalling Yosemite to return the machine, I uninstalled Office and removed all traces of it. Immediately the issue cleared up. My wife has been using the MBP for 6+ hours and everything has been working smoothly.


    TL;DR - consider the possibility of MS Office (or other software) interfering with the trackpad.
     

Share This Page