Trackpad lags after sleep mode! Any fix?

Discussion in 'MacBook Pro' started by Swift Sketcher, Dec 30, 2007.

  1. Swift Sketcher macrumors regular

    Joined:
    Dec 26, 2007
    #1
    Almost every time I open my MBP from sleep mode, the trackpad response is slow and lags unless I do restart. My Mac is only a week old, and is running on leopard. Any fix for this?
     
  2. skyrider007 macrumors 65816

    skyrider007

    Joined:
    Aug 5, 2007
    Location:
    Bangkok
    #2
    That is normal and there is no fix. Perhaps you could try logging out next time or use an external mouse.
     
  3. Dybbuk macrumors 6502a

    Joined:
    Aug 8, 2006
    #3
    Whoa, that's not normal. That can't be normal.
     
  4. Swift Sketcher thread starter macrumors regular

    Joined:
    Dec 26, 2007
    #4
    Normal? No way:(

    Also, sometimes it takes my MBP quite a while to turn on from sleep mode. Sometimes I need to press the power button for it to "wake up", and even then there's a huge delay..

    I love my Mac, but these annoyances are starting to worry me!
     
  5. Pim macrumors member

    Pim

    Joined:
    Jun 4, 2007
    Location:
    Utrecht, The Netherlands
    #5
    Me too, these things ar all Leopard specific, right?
     
  6. tibi08 macrumors 6502a

    tibi08

    Joined:
    Sep 17, 2007
    Location:
    Brighton, UK
    #6
    I suffer from both these problems too, on my 15" Santa Rosa MBP. However, they are relatively unusual.

    I found that by closing most of my open applications, the system will resume normal operation, hence no reboot is necessary. Obviously for the second problem (time to wake) there's not much you can do!

    Some applications seem to make the situation worse - for example Parallels, if you sleep with it running.
     
  7. nsbio macrumors 6502a

    nsbio

    Joined:
    Aug 8, 2006
    Location:
    NC
    #7
    It is odd, but I noticed similar behavior on my G4 PB since installing Leopard. Except that in my case it happens maybe once out of 10-20 "awakenings" and lasts for about a minute and then everything goes back to normal. No restart required.
     
  8. notengolegs macrumors member

    notengolegs

    Joined:
    Dec 17, 2007
  9. Sptz macrumors regular

    Joined:
    Aug 8, 2007
    #9
    This happens to me with Leopard (not with Tiger), and I have to reboot.... either the mouse becomes laggy or it reacts as though it has 100% sensitivity... I have all updates this is completely ridiculously from apple
     
  10. Swift Sketcher thread starter macrumors regular

    Joined:
    Dec 26, 2007
    #10
    Ha, the 100% sensitivity trackpad was the latest thing to happen to me. It went from super sensitive to absolutely no response at all- had to do another reboot...

    Also, my software is completely up to date.
     
  11. Hydramus macrumors member

    Joined:
    Jun 30, 2007
    #11
    Its happened to me 2 or 3 times since i installed leopard on my MBP, although i think i remember it happening with tiger too, can't remember.
     
  12. brock2621 macrumors 6502a

    brock2621

    Joined:
    Jun 8, 2007
    Location:
    Kentucky
    #12
    Yeah it's happened to be a couple times as well in Leopard...
     
  13. claychicken macrumors newbie

    Joined:
    Dec 26, 2007
    #13
    hey it used to happen on my mbp, but then I uninstalled the istat widget and now it doesn't happen anymore - some leopard compatibility problem. Hope this helps ;)
     
  14. tibi08 macrumors 6502a

    tibi08

    Joined:
    Sep 17, 2007
    Location:
    Brighton, UK
  15. Mantasis macrumors member

    Joined:
    Dec 25, 2007
  16. packgrad2000 macrumors regular

    Joined:
    Sep 19, 2007
    #16
    Yep me too. I'm restarting 1-2 times a day now because of this. Only seems to happen after it doesn't want to wake up. I took it in to an Apple store and the genius there hadn't heard of this problem, and said it wasn't a "known" issue for Apple (ie don't look for a fix for it). I'm starting to hate Leopard (I'm 98% sure it never happened with Tiger).
     
  17. HALTAH macrumors newbie

    Joined:
    Dec 29, 2007
    Location:
    South Jersey Shore
    #17
    happened to me today, with trackpad and external bluetooth mouse. requirede a restart.
     
  18. Swift Sketcher thread starter macrumors regular

    Joined:
    Dec 26, 2007
    #18
    Okay, it's definitely the istat widget that is causing the problem. As soon as I removed it, my trackpad issues/sleep mode delays stopped completely. Uninstall the istat widget and that should fix it all! Thanks claychicken:)
     

Share This Page