Trackpad not clicking

Discussion in 'MacBook Pro' started by shellshock1911, Mar 26, 2011.

  1. shellshock1911 macrumors newbie

    Joined:
    Mar 26, 2011
    #1
    My trackpad recently started experiencing issues with clicking when I'm using Mac OSX. When I start the computer, it clicks for a few seconds then stops working. I have an external Logitech mouse that cannot click as well. I can move the cursor and right click, which allows me to shut down and restart the computer, but that's it. The keyboard works as well. I am currently running Windows 7 Ultimate with Boot Camp to create this thread, and both the trackpad and the Logitech mouse work here, but not when I go back to OSX. Any help would be much appreciated.
     
  2. gwydion88 macrumors newbie

    Joined:
    Sep 12, 2011
    #2
    a possible solution

    I had similar issues. I tried all the other solutions I found on the internet, including resetting the NVRAM, etc. What worked for me was to turn on MouseKeys in the Universal Access control panel (I used command-space to go to spotlight and typed in "Universal Access", then tabbed, used arrow keys, space bar, etc to select the option to turn it on). This allows you to use the "789uiojkl" keys to move the mouse around and click. After I "clicked" on something by pressing "u" my trackpad and mouse left click started working again. Hope this helps!
     
  3. nzmc36 macrumors member

    Joined:
    Jun 5, 2006
    Location:
    Gainesville FL
    #3
    Yet another MBP with duff/off/non-clicking track-pad

    Yeah - I don't know what's going on either. Tried a number of possible fixes but nothing works. Haven't taken the back off yet to look for a battery fault - guess that's next on the list.

    The problem was certainly an issue after the last Lion up-date (not an issue before), so I'm leaning toward software issue not hardware.

    Any more suggestions, other than back to Apple (no stores near here).

    Cheers -
    Pete


     

Share This Page