Trackpad not responding to click or ?

Discussion in 'MacBook Pro' started by lsh, Feb 16, 2017.

  1. lsh macrumors 6502

    Joined:
    Feb 6, 2012
    Location:
    Cincinnati, OH
    #1
    I have a 2016 15" pro with touch bar and upgraded graphics.
    I've have intermittent problems where it seems to lock up. I can touchpad the cursor around the screen, and the dock items even enlarge when I cursor over, but clicking anywhere does NOTHING.
    I'm thinking either something is hung up OR the trackpad isn't working.

    Any suggestions on how I figure out what is going one here? Anyone else with this problem?

    In almost all cases, eventually it works again. But the last time, I had to force power off.
     
  2. bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #2
    Seems like a hardware problem. I'd bring it back ASAP.
     
  3. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #3
    How long have you had the machine? What software are you running?
     
  4. Mindinversion macrumors 6502

    Mindinversion

    Joined:
    Oct 9, 2008
    #4
    SMC reset, download Onyx and do an automated maintenance. Could very well be software/os related.
     
  5. lsh thread starter macrumors 6502

    Joined:
    Feb 6, 2012
    Location:
    Cincinnati, OH
    #5
    It just happened again when I was doing a fast scroll in Safari using quick gestures to flip up or down the webpage. It's as if I did something to freeze the display - as if it was locked in.

    With the Touchbar, I had partial use: Volume worked, so did Siri from the touchbar. But nothing else, including switch Safari tabs although the touchbar displayed the tabs.
    Using voice commands, I could launch Activity Monitor but there was no data in the window - just all blank.
    I could also use voice commands to open Outlook.
    Clicking anything using the trackpad did nothing.
    But again, the cursor did move and the and cursor over the dock did magnify the apps.
    I ended up powering off to restart. I didn't try to ask Siri to restart - I will next time.

    I'm hesitant to take it in because they kept my daughter's for 3 weeks trying to fix the sticky 'U' key that had a problem from day 1.

    Apps open: Outlook, VMWare (running Win10), Safari, Messages.

    I'll look into the SMC reset and Onyx. Thanks for these suggestions.
     
  6. lsh thread starter macrumors 6502

    Joined:
    Feb 6, 2012
    Location:
    Cincinnati, OH
    #6
    Apparently this problem is wide spread. Here's the workaround: press the < on the touchbar to expose the Launchpad icon. Press this. It worked for me - but it's just a workaround. Hopefully the people working with Apple support are able to help find a permanent solution.
     

Share This Page