Trackpad not working correctly since upgrade to 10.11.3

Discussion in 'OS X El Capitan (10.11)' started by quaffa, Feb 1, 2016.

  1. quaffa macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #1
    I accepted an update to OSX 10.11.3 this morning, and now I notice that my trackpad doesn't seem to be doing all it should. Has anyone else experienced this?

    For some reason I now cannot right-click by clicking with two fingers any more. (I could this morning.) And I don't appear to be able to shift between desktops with a there-fingered swipe anymore either. (Ditto)

    The trackpad will accept a single finger click as a left-click, and I can also scroll using a two-finger vertical swipe and navigate between Safari pages with a two-finger horizontal swipe, but as I say, I cannot two-finger click.

    The same thing is true on another user account, so it's not user-specific.

    I've checked System Prefs>Trackpad, and all the correct options are ticked. I have even changed the options, un-ticked them and re-set them back, but it makes no difference.

    I have also restarted the computer several times since the upgrade to no effect. I'm running a late 2010 MacBook Pro with 8GB memory installed.

    Has anyone any ideas please?
     
  2. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
  3. 66gonzo macrumors member

    Joined:
    Jul 16, 2012
    #3

    I've noticed the exact same thing on my 2011 MBP.

    I noticed the reply advising to use TM to revert back. I'm not 100% sure how that is done without losing updates to working documents. Is this simple? Are you restoring everything from when the MBP was running 10.11.2 (not something that I want)??
     
  4. OldGreyGuy macrumors member

    Joined:
    Jan 14, 2014
    Location:
    Near Brisbane, Australia
    #4
    I had a few problem with the trackpad after the 10.11.2 upgrade and during the troubleshooting I noticed my mouse double-click speed had changed to the fastest possible setting. My problems were typified by problems clicking using the tap settings, things randomly selecting and unselecting, etc. I changed the speed of the double-click for the mouse to a more reasonable setting and my trackpad reverted to the expected behaviour.
     
  5. quaffa thread starter macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #5
    It isn't all that difficult https://support.apple.com/kb/PH18846?locale=en_US

    But, having now started the process, I wouldn't recommend it. I started at noon, and it's been going three hours so far. 'Time remaining' is currently showing as '14 hours and 45 minutes' I wouldn't have started it if I'd known...

    And you're right, it does erase everything on the hard disk, but presumably that will all be restorable as well from the back up I started immediately before beginning.
     
  6. quaffa thread starter macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #6
    Actually, now that everything's settled down my Mac seems a whole lot faster for some reason, so maybe it was worth the effort and time after all.

    One thing I did forget, though, was to turn off software updates in System Prefs once I'd reverted back... So having spent all that time yesterday without my computer, this morning I keep being reminded that there is an update to 10.11.3 ready to install that will require a restart. (It downloaded the update overnight I think, but didn't restart unattended.)

    The only options I seem to have for this 10.11.3 update is for it to keep reminding me about itself, which is going to get very annoying. Is there any way, now that it has apparently downloaded, for me to tell my Mac to forget about it altogether, and stop reminding me that it's there please?
     
  7. StarShot macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #7
    My trackpad problem is different, but I'm adding here anyway...

    I'm starting to get TORQUED about the trackpad that in previous version of OS-X I was able to turn off AND keep off.

    MacBook Air
    macOS Sierra ver 10.12.1

    The ONLY way I can turn off and KEEP off the trackpad from being active is to go into System Preferences/Accessibility/Mouse and Trackpad and UNCHECK "Ignore built-in trackpad...".

    Then reboot the computer and once again go into System Preferences and turn the "Ignore..." feature back on. Then as long as I don't reboot the computer or run the battery down to zero, the Ignore feature remains on (checked). But if I reboot, the trackpad becomes live again and once again, I have to repeat this BORING procedure.

    I realize Apple designers love the trackpad, but I'm OLD school and vastly prefer my mouse. Yes, I realize I can use the mouse with the trackpad active, but if my palm accidentally brushes the trackpad, my cursor immediately goes to Timbuktu. It's especially annoying if I'm typing and the cursor moves to another place on the page and enters garbage until I find the cursor and backspace the garbage out.
     

Share This Page