Trackpad problems? Two-finger+click (right-click emulate) becomes hold+drag

Discussion in 'MacBook Pro' started by primerdp, Oct 15, 2009.

  1. primerdp macrumors newbie

    Joined:
    Oct 15, 2009
    #1
    Don't know if anyone else is experiencing this. The problem started today. SL10.6.1, MacBookPro2,2 (Jan07).

    Right-click emulate (two fingers + click) works for the first few minutes the OS has been booted (though with a 5-10 second mouse-lag after the click). Then, any time I attempt to right-click (emulate), the action becomes the same as hold and drag. Exact order of events: two-finger+click on a file, nothing happens until you move the mouse, and then moving the mouse then drags the file (the button is not being held).

    Tried deleting everything from /Library/Contextual Items Menu. No luck.
    Have check Console (all messages), and have found nothing that I can conclude that coincides with the event.

    Anyone else having this problem? Any ideas??
     
  2. primerdp thread starter macrumors newbie

    Joined:
    Oct 15, 2009
  3. primerdp thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #3
    Problem solved. Needed to completely replace topcase. A note for those doing this at home: try to buy the topcase alone, and reuse the keyboard if you want to save money. Generally they won't both die at once. Just be careful with the very tiny parts :)
     

Share This Page