Trackpad stoped working!

Discussion in 'Mac Basics and Help' started by ondoin, Feb 28, 2008.

  1. ondoin macrumors newbie

    Joined:
    Feb 28, 2008
    #1
    I have an iBook G3 600 MHz and today I changed the battery with another one I got from eBay.
    Also I added 128 MB more .
    But when I turned on the computer the trackpad didn't work!
    Only the button worked.
    Now I have placed a USB mouse but I really need to have the trackpad.
    What is wrong and how can I fix it?
    Should I reset the PMU?
     
  2. AndyK macrumors 6502a

    AndyK

    Joined:
    Jan 10, 2008
    #2
    Put the old stuff back in and see if it works.

    If it does work, you've learnt a valuable lesson about buying stuff from eBay.

    If it still doesn't work, take it to an apple store / authorised repair place / phone up support.
     
  3. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #3
    It could just simply be that the cable connecting the trackpad has jostled loose. That has happened to be before when fiddling with a notebooks internals. Although this usually occurs when I completely disassemble and reassemble a notebook.
     
  4. ondoin thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #4
    I don't know how I fixed it but it works now!
    Anyway, thanks.

    BTW, Inever had any problem with stuff I got on eBay.
     

Share This Page