Trackpad tap-to-click on login screen

Whomp

macrumors newbie
Original poster
Aug 5, 2010
5
0
This setting supposedly used to work on previous versions of OS X to enable tap-clicking on the login screen, but this is no longer seems to be the case.

I've tried both

defaults write -g com.apple.mouse.tapBehavior -int 1

and

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

with each of ~/Library/Preferences, /Library/Preferences and /private/var/root/Library/Preferences (via sudo), both with and without the -currentHost flag, along with some even more obscure places such as /System/Library/User Template/{English.lproj|Non-localized}/Library/Preferences and in /System/Library/LoginPlugins/BezelServices.loginPlugin/Contents/PlugIns/AppleBluetoothMultitouchTrackpad.plist and /System/Library/Extensions/AppleBluetoothMultitouch.kext/Contents/Info.plist, all to no avail (yes, this has been seriously bugging me!)

All this has led me to the conclusion that tap-clicking is hard-coded to "off" somewhere in a login window binary. Are there any experts around here who know whether or not I'm right and if so, whether there's anything that can be done about it?
 

Whomp

macrumors newbie
Original poster
Aug 5, 2010
5
0
I wouldn't have posted if it weren't niggling away at me! I don't need it, but I want it!
 

Comeagain?

macrumors 68020
Feb 17, 2011
2,190
45
Spokane, WA
I didn't do anything, I just tried it. Then I realized you meant the login screen, not just when it prompts for a password after it's been in sleep mode. :oops:
 

Shazaam!

macrumors member
Apr 12, 2009
65
0
Tap to click is a choice made in the preference panel. Each user decides this preference so until you identify yourself by entering your password and logging in, the OS doesn't know your choice yet and defaults to a standard pad mouse click.
 

Goldfrapp

macrumors 601
Jul 31, 2005
4,966
5,949
I'm so annoyed by this too.

I didn't even know there was a Terminal command for this (at least in previous OS versions).

Somewhat related to my annoyance: does anyone know how to remove the Guest icon from the Login screen? 10.7.2 forces it to show no matter what you do in Preferences. If I'm able to remove the Guest icon, I won't care about tap-to-click so much then. Ta.
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,967
0
I don't get it. I disabled Guest and it disappeared immediately.

Are you sure it's not "Other..."?
 

henrikrox

macrumors 65816
Feb 3, 2010
1,218
2
anyone know how to remove the guest icon in 10.7.2

its really annoying having it there, and i have disabled the guest account
 

cstout

macrumors newbie
Sep 2, 2011
13
11
Guest Account Always Appearing

Though I'm researching the ability to activate tap-to-click for the login screen, I wanted to take a moment to answer a question I do have the answer to.

I don't get it. I disabled Guest and it disappeared immediately.

Are you sure it's not "Other..."?
anyone know how to remove the guest icon in 10.7.2

its really annoying having it there, and i have disabled the guest account
The reason your guest account is showing even though you have it disabled, is due to the fact that you have likely enabled "Find my Mac" in your iCloud settings. What that does is enables a special Guest account which is incredibly limited. It restarts the computer in order to be used and works as a security feature, should your computer be stolen. Once it connects back to the internet, it updates Find my Mac every chance it gets.

Though I don't like looking at it esthetically on my login screen, I appreciate the added layer of security in the event of theft.
 

cstout

macrumors newbie
Sep 2, 2011
13
11
Confirmed Working

I just found my answer, so I thought I'd share:

For old trackpads (tested on Snow Leopard):

sudo defaults write -g com.apple.mouse.tapBehavior -int 1

For multitouch trackpads (tested on Snow Leopard & Lion):

sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

You don't need to explicitly address the plist files if you use sudo. The defaults system looks in ~/Library/Preferences, /Library/Preferences, & /System/Library/Preferences in that order, stopping early when the preference is found. When writing a preference, it always puts the preference in ~/Library/Preferences. root's ~ is /private/var/root, so defaults under sudo writes to /private/var/root/Library/Preferences. And finally, the login screen runs as root, so when it starts up & looks for the preference, it looks in root's ~/Library/Preferences first.​

Found my answer on MacWorld forums, here's a direct link if you want to read more of the background.

Again, I used the above terminal command (important that you perform the action with SUDO) on 10.7.2 with a Magic Trackpad and tap-to-click now works on my login screen, not just my screensaver lock screen. I hope this helps.
 

ace.neerav

macrumors newbie
Jun 14, 2009
13
0
i'm glad to have found this post. i'm using my macbook pro with a 40 inch monitor and use it from a 12 feet distance with a wireless keyboard and a trackpad. i just tested this command and it works. thanks a lot.

now if someone knew a way to boot a macbook pro mid 2010 thats completely shut down, using either an apple wireless keyboard or magic trackpad or an apple remote. that way i can avoid going through the hassle of opening the lid and powering it on and then closing it down again.
 

john.orban

macrumors newbie
Feb 20, 2009
4
0
It works!

I'm imaging White MacBooks and ran into the Tap feature turned off. Since these are already 5 years old, some of the "mouse" buttons are getting "soft" (i.e. not working so well). I wanted to turn "Tap to Click" on, but that setting gets wiped out when the Guest user logs out (I have all students log in as Guests - sooooo much easier on sooooo many levels).

Been futzing around with this problem all day until I ran into this article and checked out the link referral. Even though that older article was written in 2007, still works with Mountain Lion on a Mid 2009 MacBook (w00t!)

This is how I did it:

Use Terminal to turn on hidden files
defaults write com.apple.Finder AppleShowAllFiles YES
killall Finder

I copied the .GlobalPreferences.plist file to my Desktop

Open .GlobalPreferences.plist in PList Editor (Fat Cat Software - $30 - Good!)
Click on the "Root" key and click the "New Child" icon in the button bar
Key = "com.apple.mouse.tapBehavior"
Class = Number
Value = 2 (I also wanted Tap and Drag - remember the button isn't reliable)

Value = 1 (if you only want Tap)

Save the file.

Now I can push the file out to the laptops that I've imaged, and/or add it to the image before I upload it to the server.

By the way setting the Trackpad and then copying over the /Guest/Library account to the User Template file doesn't work - I don't know why, but it doesn't.

Thanks to all who helped figure this out.
 

benwiggy

macrumors 68020
Jun 15, 2012
2,184
15
The following should work:

Code:
# TRACKPAD: enable tap to click for this user and for the login screen
defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -bool true
defaults -currentHost write NSGlobalDomain com.apple.mouse.tapBehavior -int 1
defaults write NSGlobalDomain com.apple.mouse.tapBehavior -int 1
 

annaluisa09

macrumors newbie
Apr 23, 2014
1
0
I just found my answer, so I thought I'd share:

For old trackpads (tested on Snow Leopard):

sudo defaults write -g com.apple.mouse.tapBehavior -int 1

For multitouch trackpads (tested on Snow Leopard & Lion):

sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

You don't need to explicitly address the plist files if you use sudo. The defaults system looks in ~/Library/Preferences, /Library/Preferences, & /System/Library/Preferences in that order, stopping early when the preference is found. When writing a preference, it always puts the preference in ~/Library/Preferences. root's ~ is /private/var/root, so defaults under sudo writes to /private/var/root/Library/Preferences. And finally, the login screen runs as root, so when it starts up & looks for the preference, it looks in root's ~/Library/Preferences first.​

Found my answer on MacWorld forums, here's a direct link if you want to read more of the background.

Again, I used the above terminal command (important that you perform the action with SUDO) on 10.7.2 with a Magic Trackpad and tap-to-click now works on my login screen, not just my screensaver lock screen. I hope this helps.
Hi there. I just upgraded my mac to 10.9.2. Will this command work on my computer, too?
 

boaltstyle

macrumors newbie
Oct 8, 2015
1
0
I actually did need to figure this out before, as my trackpad clicker is broken and I forgot my wireless mouse one time on a trip. Turns out you don't need to tap-click at login. If you just hit the left/right arrows you can toggle user icons and just hit enter to select.

I wouldn't have posted if it weren't niggling away at me! I don't need it, but I want it!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.