Trackpad Won't Register Clicks

Discussion in 'MacBook' started by kpitch5, Dec 18, 2011.

  1. kpitch5 macrumors newbie

    Joined:
    Dec 18, 2011
    #1
    I was using my 2007 Black Macbook the other day and everything was fine. I put it to sleep as usual, but he next time I tried to use it, the trackpad would move but won't click anything. (The click button and trackpad are separate, prior to the new trackpad)

    I've had Snow Leopard for over a year now and have kept my machine software up to date since I got it, so I don't think it was a bad update or the transition to Snow Leopard.

    I UNDERSTAND that there are other articles about this but none have helped.

    1) I plugged in my mouse from my Mac desktop and it moves but won't click so it isn't a hardware issue.

    2) I reset the PRAM on startup.

    3) Performed a safe boot

    4) Turned it on while holding control to bring up the control panel

    None of these 'fixes' have helped. Sometimes if I put the cursor over an app the app will enlarge, but not all the time, and it will not click. If the app does enlarge, if I continue to move it to the left and right along the other apps, the original app stays enlarged and there is no movement among the others.

    I haven't tried Repairing Permissions, because I don't know how to do it without clicking.

    I don't know what else to do without being able to click things to enter settings or preferences.

    ANY AND ALL help would be greatly appreciated.
     
  2. Jaben3421 macrumors regular

    Joined:
    Sep 18, 2011
    Location:
    CA
    #2

Share This Page