Tracks don't play correctly for one album

Discussion in 'iOS 8' started by iStorm, Feb 11, 2015.

  1. iStorm macrumors newbie

    Joined:
    Sep 18, 2012
    #1
    I recently imported an album with 12 tracks to my iTunes library and synced it to my iPhone and iPad. The track order displays and plays correctly in iTunes. The track order also displays correctly on my iPhone and iPad, however it is treating track 1 as if it is the last track in the album on both of my devices.

    Symptoms:
    • When track 1 plays on my iPhone, it says 12 of 12; track 2 will be 1 of 12 and so on (I don't think the iPad displays this info.)
    • When track 1 is done playing, the album is done playing
    • When I try to skip to track 2 from 1, the album is done playing
    • When track 12 is done playing, it jumps up and plays track 1

    Has anyone seen this issue or know what could be causing it and how to fix it? I have checked the information on the Get Info screen and sorting tab and everything looks correct. I have also tried restarting my devices as well as unsyncing all my songs and resyncing them.
     
  2. Vundu macrumors 65816

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
  3. iStorm thread starter macrumors newbie

    Joined:
    Sep 18, 2012
    #3
    I just tried that and had no luck. I removed the disc and track numbers from all songs, saved, put them back in, saved and re-synced. I also tried removing the album from iTunes, importing it back in, and re-syncing.

    I'm starting to think maybe that particular song is corrupted and is somehow causing this weird effect. I swapped tracks 1 & 2 around just to see what happens. I still have the same symptoms above, except track 2 is the one that behaves incorrectly. (ex. Track 1 will skip to track 3, and from 12 it jumps up to track 2.)
     

Share This Page