Transcend 4gb USB Flash Drive

Discussion in 'Mac Accessories' started by Pablo90, Sep 25, 2010.

  1. Pablo90 macrumors member

    Joined:
    Aug 21, 2010
    #1
    Hi guys, I have this 4gb USB Flash Drive that I used on Windows...
    Since I bought a Macbook Pro I've been using it without problems, but yesterday I saw that the MBP kept saying that there were only fews MBs free, even if I deleted everything..
    So I decided to format the drive with my MBP and all worked fine.. Then I tried it on my Windows Seven PC and it said I had to format it again in order to used it...
    So I did and now on Windows it says that I have only 200 mb available... Even if I try to format it again, both on Mac and Windows... No matter what mode I chose (Fat32, NTFS, PC Dos or sth like that and other modes on the MBP)..
    On my MBP works fine and all the 4gb...

    Can you help me please?
    Thanks, Paolo.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Your Mac sees 4 GB, but your PC sees only 200 MB. It sounds like you have two partitions on the Flash drive. You reformatted the larger partition on the Mac, but did not repartition the drive. Your smaller partition remain intact and formatted for the PC, probably FAT32.

    My guess is that your Flash drive had the God-forsaken U3 encrypted partition. U3 partitions cannot be read, written, or administered by your Mac. What I do when I purchase a new Flash drive is to first use a Windows machine to remove the U3 partition. I then use my Mac [to repartition and] reformat the drive as HFS+ for Mac use only or as NTFS using NTFS-3G for use on Mac and Windows. Ironically, I have not found a way to use Windows to format a thumb drive as NTFS. That done, I am golden.
     

Share This Page