"Transfer Purchases" not working from iPhone 3G

Discussion in 'iPhone' started by hualon, Oct 6, 2008.

  1. hualon macrumors 6502

    Joined:
    Feb 5, 2008
    #1
    I bought a couple of albums on the ITMS in iTunes, copied them to my iphone via the Sync feature, and was enjoying them while at work.

    I got home and my HDD had crashed and my time machine hadn't yet picked up the new albums so I tried to transfer them from my iPhone.

    All that happens when I engage this function is that the phone lights up, says, "Syncing", and then goes back to the locked state. No feedback, no pop up boxes, nothing. And no music is being synched back to the library! :-(

    I tried turning off the phone, turning it back on, deauthorizing my Mac, reauthorizing my Mac, and none of that has worked so far.

    Any ideas?
     
  2. Nde macrumors 6502a

    Nde

    Joined:
    Feb 12, 2008
    Location:
    Los Angeles, CA
    #2
    I don't think you can sync the other way around. In your situation, I don't think the iphone can sync music, apps, and movies back to your itunes. I think you need to re-download all your stuff in itunes. I know my Apps, I have to re-download in Itunes. Some paid apps, it would tell me its free because I have already paid for them. Maybe somebody with experience can comment.
     
  3. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #3
    Incorrect. The popup will declare that there are purchases found on device that do not appear in iTunes, would you like to transfer now?

    Have you searched support on Apple?
     
  4. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #4
    Yes, I have searched on Apple's support and I've found other people with the same problem.

    I've gone through the exact process on my 5G iPod so I know what it's supposed to do but the iPhone isn't doing it right. :(
     
  5. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #5
    I figured out the problem!

    Because the files had gotten misplaced but the entries still existed in the iTunes database the phone wouldn't transfer them; iTunes assumed that they were there.

    I connected my phone to my PC to charge while I was at the office this morning and then it hit me. I selected the option to transfer purchases and it's currently transferring over everything that I have ever bought.

    Yay!
     

Share This Page