Transferring new Iphone 4 to different at&t line - HELP ME

Discussion in 'iPhone' started by spamdumpster, Jun 23, 2010.

  1. spamdumpster macrumors 6502a

    Joined:
    Jan 22, 2008
    #1
    Bought the iPhone 4 on my wife's account b/c she qualified for upgrade pricing.

    Got iPhone this morning, called at&t to transfer all relevant info,e.g imei, sim, but when I plugged it into itunes, itunes still tried to activate on her number.

    AT&T rep said to go ahead and try to activate it anyway, but activation failed with a message regarding a bad sim. I mentioned that I had an unactivated microsim in my 3G iPad, so she said to go ahead and try that -- same error message. She told me to go to a local at&t store and get two new microsims -- one for each iDevice. It took some convincing, but they gave me to free microsims.

    Now I'm back at my desk trying, once again, to activate it on my line. Call AT&T, rep once again updated my account with the number of the new sim, imei, etc., but iTunes is STILL trying to activate on my wife's line.

    The at&t rep tried to transfer me to apple, but I told her that I wanted at&t AND apple on the line at the same time so that they couldn't pass the blame back and forth.

    Any advice?
     
  2. dakrhelmet macrumors newbie

    Joined:
    Jun 15, 2009
    Location:
    California
    #2
    Went through this yesterday. They basically have to activate on your wife's line, and then they can activate on your line. This will deactivate your wife's current sim and will require a new one also.

    I did all this yesterday and then they claimed the micro-sim was ipad specific and couldn't be used in the iphone 4. They then deactivated my iphone4...

    I came home and cut down my current sim to make it a micro-sim and plugged it in and am using the iphone4 now.

    I will call again today and see if they can give me a micro-sim to use.

    It seems ATT is really not ready for this.
     
  3. spamdumpster thread starter macrumors 6502a

    Joined:
    Jan 22, 2008
    #3
    THanks. But my problem now is that when I try to activate with my wif'es account it tells me I have a bad SIM. And, this is the second SIM to get that error message. I've already spent 4 hours dealing with this ...
     

Share This Page