Transmission no longer seeking Peers

GizmoDVD

macrumors 68000
Original poster
Oct 11, 2008
1,751
1,303
SoCal
Anyone have this issue? Transmission 2.82 is no longer seeking peers. Tried it on another computer (ML) and the same torrent starts up right away.
 

koban4max

macrumors 68000
Aug 23, 2011
1,582
0
Anyone have this issue? Transmission 2.82 is no longer seeking peers. Tried it on another computer (ML) and the same torrent starts up right away.
it happened to me..but i restarted my computer..and it went fine.
 

negativzero

macrumors 6502a
Jul 19, 2011
564
54
Try an older version like 2.80 or 2.81.
Or compile transmission yourself with xCode. Its easy :) Fixed all my problems this way.
 

2Turbo

macrumors 6502
Feb 18, 2011
360
0
Contact the developer I'm sure he'll fix it. Thanks for letting me know. I simply cannot upgrade to Mavericks unless this app works.
 

drew627

macrumors regular
Jun 26, 2013
189
3
Been using Transmission since GM here and never ran into any problems. So...
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,192
9,870
California
Nope.

Turned off my Firewall. Still having issues with not connecting to peers at all unless I restart Transmission. Using 2.8.0 now and still having issues. Very slow to download anything.
Update to 2.8.2. There was a bug in previous version that was limiting speed until you went in the speed limit options and unchecked then checked the limits.

Are you getting the green light that your port is open in the network tab of Transmission prefs?
 

GizmoDVD

macrumors 68000
Original poster
Oct 11, 2008
1,751
1,303
SoCal
2.8.2 is useless. It still won't download anything unless I close out of it several times.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,192
9,870
California
2.8.2 is useless. It still won't download anything unless I close out of it several times.
I am using 2.8.2 on OS X 10.8.5 with no issues, so you have something else going on. Maybe it just won't work with Mavericks. Have you checked the Transmission support forums regarding Mavericks?

Did you check your port like I suggested in my previous post?
 

GizmoDVD

macrumors 68000
Original poster
Oct 11, 2008
1,751
1,303
SoCal
I am using 2.8.2 on OS X 10.8.5 with no issues, so you have something else going on. Maybe it just won't work with Mavericks. Have you checked the Transmission support forums regarding Mavericks?

Did you check your port like I suggested in my previous post?
I've looked at the Transmission forums and it doesn't appear anyone else is having issues.

Yes, my port is open and green.

Overnight nothing downloaded. Red. As soon as I closed and opened Transmission it worked.
 

LucasLand

macrumors 6502a
Mar 6, 2002
748
84
New England
i had the same problem and discovered the solution and the fix was real easy. In my case I use a VPN. In my VPN settings I had to make sure that "port forwarding" was selected, direct VPN to a canada server and then restart mac. I then hovered mouse over the VPN icon at top of desktop where it showed me the port number. I then inputed port number into transmission and BAM the light turned green.

I didn't have to touch any other settings in transmission or router settings
 

chuks

macrumors newbie
Oct 14, 2014
2
0
Anyone have this issue? Transmission 2.82 is no longer seeking peers. Tried it on another computer (ML) and the same torrent starts up right away.
yes i am. and am now regretting why i upgraded.
Mine was working till i upgraded to mavericks, now even the port is showing closed with the red dot. i don't know what to do.
pls help...
 

chuks

macrumors newbie
Oct 14, 2014
2
0
Transmission 2.82 working fine here with OS X 10.9.5 and through a VPN (privateinternetaccess VPN to be specific)
Ok, i was going to try that. I got this VPN from App Store, "VPN unlimited" it refused to instal completely. but the transmission is still not working.
Which VPN are you using and which server too?
Does that mean its not working because of some settings of my Service provider?
How about the port, its still red..
 

fhall1

macrumors 68040
Dec 18, 2007
3,484
709
(Central) NY State of mind
I'm using the paid VPN service from https://www.privateinternetaccess.com/

They create a Mac download that is customized for your account that makes setup painless. Once you install it, you double-click it and setup - for me - was automatic. I then use the auto feature to let it pick a server to connect to.

Really simple and I haven't noticed any slowdown with Transmission.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.