Transmission/Quick Look Server Solution?

Discussion in 'Mac Apps and Mac App Store' started by JSK1121, Dec 11, 2007.

  1. JSK1121 macrumors member

    Nov 21, 2007
    Hey all, when I run Transmission, it seems like my Quick Look Server is trying to index every little piece of every video file I am downloading. Because of this, QLS is using like 100%-120% of my CPU and hence causes my computer to run extremely hot.

    Has there been any solution to this problem? I'd hate to have to go back to Azureus for torrents, but it seems like that is the only solution as of now.

  2. blunt99 macrumors newbie

    Mar 12, 2008
    From what I can tell, the quick look server runs when a folder is open. This seems to include minimized folders in the dock, and folders that are completely hidden by other windows. This makes some amount of sense. At any rate, it also looks like it is smart (or dumb) enough to try and create a new thumbnail whenever a file in an open folder changes.

    My suggestion is to download all your files to somewhere like ~/Downloads/inprogress/ and then move them when they are complete. Then, never open that folder up in finder.

    In addition (and I haven't quite tested this) Transmission looks like it can do something like this for in. This applies to v1.06 of Transmission, and I haven't looked at any other versions... However, if you open up the Preferences page for Transmission, and click the "Transfers" icon at the top, the settings listed look promising.

    Specifically, try putting a checkmark next to the "keep incomplete files in:" line, and changing that to some other directory (like the ~/Downloads/inprogress). Then it seems like Transmission will keep partial downloads in that directory, and place the completed ones wherever else you told it to.

    good luck

    One more thing. I would be wary of putting your temporary download folder in the dock, since the quick look server generates thumbnails for folders that are there as "stacks". You can turn that behavior off for the dock by control-clicking on the folder in the Dock and under "Display as" select "folder" instead of "stack". At the very least, this will prevent loading the thumbnails until you actually click on the folder.

Share This Page