trash empties all except for one file

Discussion in 'Mac Basics and Help' started by Sossity, Oct 28, 2012.

  1. Sossity macrumors 6502a

    Joined:
    May 12, 2010
    #1
    when I go in to empty my trash can/delete files, it will delete everything all except one file, of which I get a message saying that this item cannot be deleted because it is in use. It is not in use, it is a word document, that I think I created with open office. When i click on it, there is no put back option, & quick look does not pull anything, it is just a blank paper icon.

    I have been sort of stuck with it in the trash can for a while now, & everything else I place in the trash can empties except for it.

    Everything else seems ok, so I never got around to asking, but it is a little annoying, & can live with it as nothing else serious seems to be going on, but I would like to know why it is doing this, & if I can fix it.
     
  2. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #2
    You need to force empty via Terminal:

    Code:
    rm -rf ~/.Trash/*
    Or hold down the Option key and press Empty.

    Sometimes it has to do with disk permissions. You might want to try repairing them in Disk Utility.

    With the fact that Lion/Mountain Lion can both just reopen everything now when you restart, I wouldn't be surprised if it wasn't that either.

    Here's a read if you're interested: http://www.thexlab.com/faqs/trash.html
     
  3. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #3
    @Jessica, thank you, I had to do a force empty from the terminal, neither doing a disk permissions repair nor option plus empty trash worked.
     
  4. CatsTide macrumors 6502

    Joined:
    Sep 16, 2012
    #4
    Awesome! the force empty worked for me. Thanks
     

Share This Page