Trash error, -1407?

Discussion in 'macOS' started by lcwadman, May 8, 2010.

  1. lcwadman macrumors newbie

    Joined:
    May 8, 2010
    #1
    Hello all,

    I'm a frequenter of the MacRumors forums but have never had a problem severe enough to post about. I just noticed this today, and it has never been a problem before. I have a WD My Passport that I use as a backup for my Macbook and my home PC, and I just copied Office 2008 over there today as I got the Office 2011 beta. Regardless, I copied the files a few too many times so I attempted to delete them, and received this error from my trash:
    "The operation can’t be completed because an unexpected error occurred (error code -1407)."

    The WD has been giving me some assorted strange issues lately, this is just the latest. None of them were ever sever enough to warrant me wiping the drive. One issue is there is a file that is always in the trash when it's plugged in, I haven't ever tried really hard to get rid of it but it's name is "E577␀␀␀␀.␀␀␀" Yes, those are the correct characters at the end. It has no size, and disappears when I unmount the drive.

    I can copy items onto and off the drive, but just can't delete files from them...any suggestions? Already ran Verify Disk, no red remarks.
     
  2. marcelomc macrumors newbie

    Joined:
    Feb 15, 2011
    #2
    Similar Problem

    Don't mean to hijack, but i am having a similar problem. Except my error is: The operation can’t be completed because an unexpected error occurred (error code -8003).

    I recently restored my iMac to a factory install and dumped a bunch of apps onto my 1TB Seagate ext. hard drive I use as a back up. It was getting full and TimeMachine suggested I delete the older backups to make room for newer. I dumped a bunch of apps and other files that were on the drive and now I can't empty the trash.

    Tried secure emtpy trash, tried some of the unix code but now can't find what code it was...

    HELP!!
    THanks
     
  3. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #3
    Marcelo,

    Can you please further describe what you mean by 'dumped a bunch of apps onto the external HD?' Where did you put it?

    Does this error occur only when the external is connected, unconnected or both?

    What do you mean by Unix code? There are some very simple commands to delete your Trash contents but it would be better to try to first determine the source of the error.
     

Share This Page