"Trash" for email doesn't work

Neutral Milk

macrumors regular
Original poster
Apr 28, 2015
130
11
I use the iOS email app for work and Mailbox for personal email, and as far as I can tell when I get notifications on my watch and click "trash" in the former it doesn't actually work. The emails still sit in my inbox. "Archive" for personal emails does work.

Is this a problem others are experiencing?
 

Apples n' Stone

macrumors 65816
Apr 13, 2015
1,151
555
Maidstone, U.K
Is it storing it in the trash folder on one of your devices? (And not the other). In which case I would suggest something to do with your IMAP settings, check if it is just POP3 as that would only hit traahnon the watch. But by default thos ahould be IMAP4 so I would be suprised. Long shot, just mine seems to work! Either way, hope you get it sorted soon.
 

Neutral Milk

macrumors regular
Original poster
Apr 28, 2015
130
11
Thanks so much for your help! It isn't really a big deal.. It's only very mildly inconvenient.

Anyway it's an exchange account. Looking in the settings I'm not sure if exchange accounts are typically IMAP or POP3. The advanced settings didn't say.

It doesn't seem to delete from either place. Not my phone or the account online.
 

Apples n' Stone

macrumors 65816
Apr 13, 2015
1,151
555
Maidstone, U.K
Thanks so much for your help! It isn't really a big deal.. It's only very mildly inconvenient.

Anyway it's an exchange account. Looking in the settings I'm not sure if exchange accounts are typically IMAP or POP3. The advanced settings didn't say.

It doesn't seem to delete from either place. Not my phone or the account online.
Go to the settings app > Mail > Exchange. See what it says there? On my iPad I get this view: (Note "iMap")
 

Attachments

Neutral Milk

macrumors regular
Original poster
Apr 28, 2015
130
11
It says Exchange where yours says IMAP. I think because I set it up as an exchange account (rather than, say, other) it's showing up that way.
 

Apples n' Stone

macrumors 65816
Apr 13, 2015
1,151
555
Maidstone, U.K
Try setting this up again as Other? I believe it should default to exchange anyway but if this was a one off mistake it should be righted. Failing that, go on a computer and delete an email. This should work as IMAP deleting it off the server the phone would be accessing.
 

Neutral Milk

macrumors regular
Original poster
Apr 28, 2015
130
11
That's the weird thing.. If I delete off my computer it deletes off my phone, and if I delete from my phone it deletes off the computer.

This leads me to believe it isn't an issue with IMAP v. Pop3 as that issue would be present in my phone not just my watch.

The disconnect seems to be between the watch and the phone specifically. Deleting from the watch deletes from neither the phone or the computer.
 

Apples n' Stone

macrumors 65816
Apr 13, 2015
1,151
555
Maidstone, U.K
That's the weird thing.. If I delete off my computer it deletes off my phone, and if I delete from my phone it deletes off the computer.

This leads me to believe it isn't an issue with IMAP v. Pop3 as that issue would be present in my phone not just my watch.

The disconnect seems to be between the watch and the phone specifically. Deleting from the watch deletes from neither the phone or the computer.
Ah, I thought you were telling me you could not delete from the server on either of them!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.