Trash is stuck on "emptying"

Discussion in 'Mac Basics and Help' started by jive turkey, Dec 10, 2008.

  1. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #1
    My trash bin was rather full so I decided to empty it this morning. It was going along swimmingly at first, but about 75% of the way through (according to the progress bar), it stopped progressing. It has now been sitting at "Emptying the trash. . . items to delete: 139" for about 12 hours. I tried logging off and I tried rebooting, but the system tells me it isn't allowed because Finder is busy.

    Do I have any alternatives besides holding down the power button and forcing the machine off? I fear that may harm my drive. I don't see anything in activity monitor that indicates trash deletion for me to try a force quit on.

    Thanks!
     
  2. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #2
    1. Force quit Finder
    2. Open Terminal
    3. cd ~/.Trash
    4. rm -fr * (make very very very sure you are in the .Trash folder as this command will erase ALL files with no prompt. You have been warned.)
    5. exit Terminal
     
  3. jive turkey thread starter macrumors 6502

    Joined:
    Mar 15, 2008
    #3
    Thanks. When I forced quit on Finder it actually cut off the computer, so I no longer have to worry about the consequences of forcing a restart! The rest of your steps worked fine. Thanks again.
     

Share This Page