Trash Won't Empty When HDD plugged in?!

Discussion in 'Mac Basics and Help' started by LP15, Jun 22, 2009.

  1. LP15 macrumors newbie

    Joined:
    Apr 15, 2009
    #1
    YES TITLE THREAD IS MEANT TO BE EHD (external hard drive)! lol

    I've been thru a million google searches and forums and I can't find this problem anywhere. I put a folder with music in it in the trash (from a Lacie portable HDD) and didn't realise it was locked. Now I can't delete it as I don't have sufficient privileges.

    I can't change it in the folder get info view either and no matter whether I try put it on my desktop or back on the HDD it won't move or delete whats in the trash. I tried doing a terminal delete and dropping the folder into terminal but it says the directory doesn't exist?!

    Help??

    EDIT: I'm thinking it stuck in the HDD which is why whenever its plugged in the folder is in the trash. I'm looking for a way around having to format my EHD
     
  2. iKolja macrumors newbie

    iKolja

    Joined:
    Jan 27, 2009
    Location:
    Serbia, Belgrade
    #2
    tried holding option/alt while deleting from trash ?
     
  3. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #3
    Try running the following in Terminal:

    sudo rm -rf [drag and drop your external hard drive icon onto the Terminal window]/.Trashes

    There should be no space before .Trashes. For example, I have a hard drive named Kohlberg, so for me it would be:

    sudo rm -rf /Volumes/Kohlberg/.Trashes

    Be careful to type this command exactly as I have here. This one can really screw up your system with no confirmation message if you type it wrong.
     
  4. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #4
    have you tried holding alt/option as you empty the trash, that generally gets rid of all locked folders.

    I cant think of anything else that it could be, other than repairing permissions.

    Sorry i cant be of more help.

    PTP
     
  5. LP15 thread starter macrumors newbie

    Joined:
    Apr 15, 2009
    #5
    all good. just used my pc laptop to delete it. stupid mac and pc tiffs. lol
     

Share This Page