Trashed Messages beta and now I can't empty trash because of iChat

Discussion in 'Mac Basics and Help' started by miknos, Nov 19, 2012.

  1. miknos, Nov 19, 2012
    Last edited: Nov 19, 2012

    miknos Suspended


    Mar 14, 2008
    Title says it all,

    I used TrashMe app to remove Messages beta and without noticing It moved iChat to trash can too. When I tried to empty the trash, it wasn't possible.

    Now I can't move iChat out of the trash can nor empty it.

    I hear you can install from OS X Lion disk but I was looking for a way to force empty. Tried the command line and it shows this:
    .Trash/ Permission denied

    In Windows I know it is because you're trying to empty while using an app. How do I quit the app so I can empty the trash???
  2. GGJstudios macrumors Westmere


    May 16, 2008
    That's one reason I don't recommend such apps. In most cases, app removal software doesn't do a thorough job of finding and removing files/folders related to deleted apps. For more information, read this and this. If you just want to delete the app, drag the .app file to the trash. No other software needed. If you want to completely remove all associated files/folders, no removal apps will do the job.

    The most effective method for complete app removal is manual deletion:

    For problems deleting items or emptying the trash, you may find some useful ideas here:
    You can either use Command-Option-Esc to access the Force Quit menu, or launch Activity Monitor to locate and quit or force quit any running app.
  3. miknos thread starter Suspended


    Mar 14, 2008
    Tried terminal and didn't work.

    I decided to try a restart again and worked, so I guess that was the only thing I could do.

    Thanks for the reply. I'm checking your method of removing apps instead of using those commercial apps.

Share This Page